Closed Bug 1563905 Opened 11 months ago Closed 11 months ago

PERMA TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking array values: Check all menuitems are displayed correctly. - got 1, expected 2 when Gecko 69 merges to Beta on 2019-07-01

Categories

(Toolkit :: Password Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: dvarga, Assigned: MattN)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central as beta simulation: https://hg.mozilla.org/try/rev/b9c00793544c6bc8bd8f1d425a24dfa11afec515

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=255093816&repo=try&lineNumber=4864

[task 2019-07-06T12:00:51.536Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | the footer text is shown correctly 
[task 2019-07-06T12:00:51.537Z] 12:00:51     INFO - Buffered messages finished
[task 2019-07-06T12:00:51.537Z] 12:00:51     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking array values: Check all menuitems are displayed correctly. - got 1, expected 2
[task 2019-07-06T12:00:51.539Z] 12:00:51     INFO - SimpleTest.is@https://example.com/tests/SimpleTest/SimpleTest.js:320:16
[task 2019-07-06T12:00:51.540Z] 12:00:51     INFO - checkArrayValues@https://example.com/tests/toolkit/components/satchel/test/satchel_common.js:66:3
[task 2019-07-06T12:00:51.541Z] 12:00:51     INFO - checkAutoCompleteResults@https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/pwmgr_common.js:77:3
[task 2019-07-06T12:00:51.541Z] 12:00:51     INFO - test_form1_menu_shows_two_logins_same_usernames_for_different_subdomain@https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html:113:3
[task 2019-07-06T12:00:51.542Z] 12:00:51     INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-07-06T12:00:51.543Z] 12:00:51     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Check all menuitems are displayed correctly. Checking array entry #0 - got "dsdu1", expected "dsdu1 (Jul 6, 2019)"
[task 2019-07-06T12:00:51.544Z] 12:00:51     INFO - SimpleTest.is@https://example.com/tests/SimpleTest/SimpleTest.js:320:16
[task 2019-07-06T12:00:51.545Z] 12:00:51     INFO - checkArrayValues@https://example.com/tests/toolkit/components/satchel/test/satchel_common.js:72:5
[task 2019-07-06T12:00:51.545Z] 12:00:51     INFO - checkAutoCompleteResults@https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/pwmgr_common.js:77:3
[task 2019-07-06T12:00:51.547Z] 12:00:51     INFO - test_form1_menu_shows_two_logins_same_usernames_for_different_subdomain@https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html:113:3
[task 2019-07-06T12:00:51.548Z] 12:00:51     INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-07-06T12:00:51.549Z] 12:00:51     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Check all menuitems are displayed correctly. Checking array entry #1 - got undefined, expected "dsdu1 (Jul 6, 2019)"
[task 2019-07-06T12:00:51.550Z] 12:00:51     INFO - SimpleTest.is@https://example.com/tests/SimpleTest/SimpleTest.js:320:16
[task 2019-07-06T12:00:51.551Z] 12:00:51     INFO - checkArrayValues@https://example.com/tests/toolkit/components/satchel/test/satchel_common.js:72:5
[task 2019-07-06T12:00:51.552Z] 12:00:51     INFO - checkAutoCompleteResults@https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/pwmgr_common.js:77:3
[task 2019-07-06T12:00:51.552Z] 12:00:51     INFO - test_form1_menu_shows_two_logins_same_usernames_for_different_subdomain@https://example.com/tests/toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html:113:3
[task 2019-07-06T12:00:51.553Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking form1 username is:  
[task 2019-07-06T12:00:51.554Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking form1 password is:  
[task 2019-07-06T12:00:51.555Z] 12:00:51     INFO - 1 form(s) processed
[task 2019-07-06T12:00:51.555Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | password should match the login that was selected 
[task 2019-07-06T12:00:51.556Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking form1 username is: dsdu1 
[task 2019-07-06T12:00:51.557Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking form1 password is: dsdp1 
[task 2019-07-06T12:00:51.558Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking form1 username is:  
[task 2019-07-06T12:00:51.558Z] 12:00:51     INFO - TEST-PASS | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Checking form1 password is:  
[task 2019-07-06T12:06:17.768Z] 12:06:17     INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-07-06T12:06:17.769Z] 12:06:17     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/passwordmgr/test/mochitest/test_basic_form_autocomplete_subdomain.html | Test timed out. 
[task 2019-07-06T12:06:17.769Z] 12:06:17     INFO - SimpleTest.ok@https://example.com/tests/SimpleTest/SimpleTest.js:275:18
[task 2019-07-06T12:06:17.769Z] 12:06:17     INFO - reportError@https://example.com/tests/SimpleTest/TestRunner.js:121:22
[task 2019-07-06T12:06:17.769Z] 12:06:17     INFO - TestRunner._checkForHangs@https://example.com/tests/SimpleTest/TestRunner.js:142:7
[task 2019-07-06T12:06:18.816Z] 12:06:18     INFO - GECKO(3153) | Removing 1 popup notifications.
[task 2019-07-06T12:06:18.858Z] 12:06:18     INFO - GECKO(3153) | MEMORY STAT | vsize 20974515MB | residentFast 761MB

More likely from bug 1563325 because the second failing test test_basic_form_honor_autocomplete_off.html didn't get modified.

Flags: needinfo?(MattN+bmo)
Regressed by: 1563325
No longer regressed by: 1541557

Back to bug 1541557, noticed the missing date now.

Flags: needinfo?(kmaglione+bmo)
Regressed by: 1541557
No longer regressed by: 1563325

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #3)

Back to bug 1541557, noticed the missing date now.

I don't know what this means but the cause is likely bug 1563325 .

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(MattN+bmo)
Flags: needinfo?(kmaglione+bmo)
Keywords: regression
Regressed by: 1563325
No longer regressed by: 1541557
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/68862d6e2d22
Enable eTLD+1 login lookup in test_basic_form_autocomplete_subdomain.html. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.