Closed Bug 1563923 Opened 4 years ago Closed 4 years ago

Can not switch browser language to English

Categories

(Firefox :: Untriaged, defect)

69 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: margareq, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/18.17763

Steps to reproduce:

Bug happend automatically after update on ~ Jul 3-4.

Actual results:

I'm using Firefox Developer Edition Version 69.0b2 on Ubuntu 19.04. After latest update (~2 days ago) browser language was switched from English to Ukrainian and I can't change it back.
Detailed info on screenshots:
https://ibb.co/nBtqWLt
https://ibb.co/kJ5JLvJ

Expected results:

Language shouldn't have changed.

Actually, my user agent is Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0

Do you have a language pack installed in about:addons for English? Is it enabled? Can you try to manually search for updates for add-ons?

Did you add English from preferences in the past, or does it come with your distribution?

(In reply to Francesco Lodolo [:flod] from comment #2)

Do you have a language pack installed in about:addons for English? Is it enabled? Can you try to manually search for updates for add-ons?

Did you add English from preferences in the past, or does it come with your distribution?

No, I have no language packs installed.
I added English from preferences after installing Firefox (default language was Ukrainian).

When I'm trying to install any language pack I get the next error - "Could not install the game due to it's incompatibility with Firefox Developer Edition 69.0."

Detailed on screenshot - https://ibb.co/vzn3fs4

(In reply to margareq from comment #3)

No, I have no language packs installed.
I added English from preferences after installing Firefox (default language was Ukrainian).

You should have one, because adding the language from preferences does exactly that. It should be disabled because the update changed the compatibility.

Today there should be language packs for 69 in AMO. Can you try to change your language from preferences tomorrow, and see if English is available again?

Unfortunately, language packs are not an option for Developer Edition. For the first week of the cycle, they'll just get disabled. Bug 1564433 is going to disable language switching by default for Developer Edition, while it will remain enabled for Beta and Release.

If you want to use Developer Edition in a different language, the safest way is to install the version localized in that language
https://www.mozilla.org/en-US/firefox/developer/all/

Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.