Closed Bug 1565485 Opened 4 months ago Closed 4 months ago

Debugger in not showing up ( only blank white screen )

Categories

(DevTools :: Debugger, defect, P1, blocker)

70 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox68 unaffected, firefox69+ verified, firefox70+ verified)

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 + verified
firefox70 + verified

People

(Reporter: tripurari001, Assigned: jlast)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [debugger-mvp])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

I updated Nightly to latest version
did a restart
and when I opened developer tool the debugger tab in only blank white screen

I have attached a gif

I tried to restart in Firefox-safe-mode but no luck

I am using 70.0a1 (2019-07-11) (64-bit) On macbook pro 2017 os 10.14.5

Actual results:

Debugger tab showing blank screen

Expected results:

Debugger panel should have appear with file tree and other stuff like breakpoints and all

Component: Untriaged → Debugger
Product: Firefox → DevTools

I'm seeing this as well. The debugger seems broken in the content view and the browser toolbox.

On the browser console, this appears when opening debugger:

TypeError: "expandedCategories is undefined"
    renderCategoryHeading resource://devtools/client/debugger/src/components/SecondaryPanes/EventListeners.js:70
    render resource://devtools/client/debugger/src/components/SecondaryPanes/EventListeners.js:157
    render resource://devtools/client/debugger/src/components/SecondaryPanes/EventListeners.js:153
    finishClassComponent resource://devtools/client/shared/vendor/react-dom.js:10332
    updateClassComponent resource://devtools/client/shared/vendor/react-dom.js:10295
    beginWork resource://devtools/client/shared/vendor/react-dom.js:10894
    performUnitOfWork resource://devtools/client/shared/vendor/react-dom.js:12713
    workLoop resource://devtools/client/shared/vendor/react-dom.js:12730
    renderRoot resource://devtools/client/shared/vendor/react-dom.js:12770
    performWorkOnRoot resource://devtools/client/shared/vendor/react-dom.js:13359
    performWork resource://devtools/client/shared/vendor/react-dom.js:13281
    performSyncWork resource://devtools/client/shared/vendor/react-dom.js:13253
    requestWork resource://devtools/client/shared/vendor/react-dom.js:13153
    scheduleWork$1 resource://devtools/client/shared/vendor/react-dom.js:13022
    scheduleRootUpdate resource://devtools/client/shared/vendor/react-dom.js:13566
    updateContainerAtExpirationTime resource://devtools/client/shared/vendor/react-dom.js:13581
    updateContainer resource://devtools/client/shared/vendor/react-dom.js:13608
    render resource://devtools/client/shared/vendor/react-dom.js:13853
    legacyRenderSubtreeIntoContainer resource://devtools/client/shared/vendor/react-dom.js:13965
    unbatchedUpdates resource://devtools/client/shared/vendor/react-dom.js:13478
    legacyRenderSubtreeIntoContainer resource://devtools/client/shared/vendor/react-dom.js:13961
    render resource://devtools/client/shared/vendor/react-dom.js:14012
    renderPanel resource://devtools/client/debugger/src/utils/bootstrap.js:74
    bootstrapApp resource://devtools/client/debugger/src/utils/bootstrap.js:124
    onConnect resource://devtools/client/debugger/src/client/index.js:98
react-dom.js:11273:13
Severity: normal → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Blocks: dbg-70
Priority: -- → P1
Whiteboard: [debugger-mvp]

Jason, can you please take a look at this.

Thanks,
Honza

Flags: needinfo?(jlaster)

I just ran this from bisect, it was caused by bug 1560942.

Regressed by: 1560942

I had similar issue, message was a bit different though:

TypeError: "categories is undefined"
    render resource://devtools/client/debugger/src/components/SecondaryPanes/EventListeners.js:153
    [...}
    renderPanel resource://devtools/client/debugger/src/utils/bootstrap.js:74
    bootstrapApp resource://devtools/client/debugger/src/utils/bootstrap.js:124
    onConnect resource://devtools/client/debugger/src/client/index.js:98

I can't reproduce right now, but I think when I saw it I had previously some event breakpoint turned on (because the page did paused and I saw the overlay in the content, and the debugger tab header icon was green, but debugger panel was blank)

Thanks for the report, I'll look into it today. Just to clarify, is this Nightly only?

Flags: needinfo?(jlaster)

All reports here and in Slack were for Nightly, so yes.

Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Attachment #9077805 - Attachment description: Bug 1565485 - Fix debugger schema validation. r=davidwalsh → Bug 1544329 - Fix debugger schema validation. r=davidwalsh
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d1e7315a88f3
Bug 1544329 - Fix debugger schema validation. r=davidwalsh
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Yes The favorite debugger is live again

Thank you folks

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(jlaster)

Beta/Release Uplift Approval Request

  • User impact if declined: This patch is required if we land (1560942). It also is not needed if we do not land (1560942)
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It only affects the debugger.
  • String changes made/needed:
Flags: needinfo?(jlaster)
Attachment #9081296 - Flags: approval-mozilla-beta?
Attachment #9077805 - Flags: approval-mozilla-beta?
Attachment #9077805 - Flags: approval-mozilla-beta?
Comment on attachment 9081296 [details] [diff] [review]
beta-schema-v1.patch

Fixes a regression from bug 1560942. Approved for 69.0b9.
Attachment #9081296 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

I've tried to reproduce but I wasn't able to do that because can't update Firefox to a certain build. Tripurari Shankar could you help me and verify this issue.

Flags: qe-verify+ → needinfo?(tripurari001)

(In reply to Timea Zsoldos [:zstimi/tzsoldos], Desktop Release QA from comment #15)

I've tried to reproduce but I wasn't able to do that because can't update Firefox to a certain build. Tripurari Shankar could you help me and verify this issue.

I had this issue in Firefox Nightly ( 2019-07-12 )
then it got fixed on a update on ( 2019-07-17 )

after that I never got this issue neither in Nightly nor in Developer Edition ( i use both [nightly and dev-edition] on daily basis for my web development)

Please let me know if you require any other information Thanks

Flags: needinfo?(tripurari001)

I verified on Firefox 70.0a1 and 69.0b10 builds, using macOS 10.14, Win 10 x64 and Ubuntu 18.04 x64. Based on comment 16 I can confirm the issue is fixed. Thanks Tripurari Shankar!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.