Closed Bug 1565499 Opened 5 months ago Closed 5 months ago

Allow changing the selected WebSocket row with arrow keys

Categories

(DevTools :: Netmonitor, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1561873

People

(Reporter: fvsch, Unassigned)

Details

Behavior should be the same as in the requests list.

Up and Left keys: select previous row.
Down and Right keys: select next row.

UX and localization question

Should we really use the Left and Right keys for that (in both WebSockets and the main request list)? "Right means next" seems to be very dependent on users working in a left-to-right locale, and since the list is vertical I'm not sure it makes much sense anyway? (Just tested in RTL and we still use Right to mean "next", which feels awkward.) Should we restrict to just Up and Down? Or alternatively invert the meaning of Left and Right keys depending on the layout direction?

I'm tentatively making this block bug 1564105, but we could deprioritize it and not make it block enabling the WS tab.

(In reply to Florens Verschelde :fvsch from comment #1)

I'm tentatively making this block bug 1564105, but we could deprioritize it and not make it block enabling the WS tab.

I don't think this is a blocker for enabling the feature on Nightly, but Harald WDYT?

Honza

Flags: needinfo?(hkirschner)

Hmm I think you're right, I misread bug 1564105 and missed that it's about enabling on Nightly.

No longer blocks: 1564105
Flags: needinfo?(hkirschner)

:fvsch, good catch on which milestone this should block – now we have the MVP meta bug

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1561873
You need to log in before you can comment on or make changes to this bug.