Closed Bug 1565518 Opened 11 months ago Closed 11 months ago

Provide preferences for bug fixes: 1563695, 1556491, 1562315

Categories

(Core :: Networking: HTTP, task, P1)

task

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr68 68+ fixed
firefox68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: mayhemer, Assigned: mayhemer)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [necko-triaged][secure-proxy-mvp])

Attachments

(1 file)

No description provided.
Depends on: 1556491
No longer depends on: 1563538
Summary: Provide preferences for bug fixes: 1563695, 1563538, 1562315 → Provide preferences for bug fixes: 1563695, 1556491, 1562315

Comment on attachment 9077649 [details]
Bug 1565518, emergency preferences to turn off individual bug fixes: 1563695, 1556491, 1562315, r=kershaw!

Beta/Release Uplift Approval Request

  • User impact if declined: Gives us a possibility to flip off individual changes (restore previous state) we want to uplift to release in case of major problems found during dogfooding/field testing/release.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: There are currently 4 bool preferences, giving combo of 16 possible configurations. Doing testing of all of them is excessive and not necessary.

Local testing on each of the pref was made.

  • List of other uplifts needed: Bug 1563695, Bug 1556491, Bug 1562315
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Extremely low risk, this is nothing more then branching of code the way as it was before each individual patch based on a pref flip (read of atomic bool values). Note that this copies the pattern from bug 1563538, which is on Nightly/Beta since Jul 7.
  • String changes made/needed: none
Attachment #9077649 - Flags: approval-mozilla-release?

Comment on attachment 9077649 [details]
Bug 1565518, emergency preferences to turn off individual bug fixes: 1563695, 1556491, 1562315, r=kershaw!

Beta/Release Uplift Approval Request

see comment 3

Attachment #9077649 - Flags: approval-mozilla-beta?
Blocks: 1565535
Pushed by honzab.moz@firemni.cz:
https://hg.mozilla.org/integration/autoland/rev/c14b15878ca3
emergency preferences to turn off individual bug fixes: 1563695, 1556491, 1562315, r=kershaw
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Tested with the prefs on by default, found no issues. Turned prefs off and tested without secure proxy and found no issues. Marking as verified.

Status: RESOLVED → VERIFIED

Comment on attachment 9077649 [details]
Bug 1565518, emergency preferences to turn off individual bug fixes: 1563695, 1556491, 1562315, r=kershaw!

prefs for http2 proxying fixes, approved for 69.0b7 / 68.0.1 / 68.1esr

Attachment #9077649 - Flags: approval-mozilla-release?
Attachment #9077649 - Flags: approval-mozilla-release+
Attachment #9077649 - Flags: approval-mozilla-esr68+
Attachment #9077649 - Flags: approval-mozilla-beta?
Attachment #9077649 - Flags: approval-mozilla-beta+

Change the status for beta to have the same as nightly and release.
For more information, please visit auto_nag documentation.

Per discussion with jcristau, we're uplifting this to 68.0.1esr also to maintain parity with the non-ESR 68.0.1 release and hopefully avoid some confusion.

ni Honza for the question in comment 13:

(In reply to Ryan VanderMeulen [:RyanVM] from comment #13)

Do we need a bug for removing these prefs eventually?

Flags: needinfo?(honzab.moz)

Yes, I will file one, but I'm not sure about a release to land it yet. I think we may need these, just in case, for a while. There is no big harm.

Flags: needinfo?(honzab.moz)
Blocks: 1579064
You need to log in before you can comment on or make changes to this bug.