Closed Bug 1565690 Opened 4 months ago Closed 4 months ago

Prefer image aspect ratio to inferred aspect ratio.

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(1 file)

This would fix all the regressions from bug 1547231.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa0016d9f9f8
When inferring an aspect ratio from an image's width and height attribute, only honor it if we don't have the real image aspect-ratio. r=dholbert
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17815 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Upstream PR merged
Duplicate of this bug: 1565607
Duplicate of this bug: 1565598
Duplicate of this bug: 1564069

Should this lead to a spec change too? Or did it?

Flags: needinfo?(emilio)

I wanted to wait for it to get a spec change before turning it on on release, see near the end of https://github.com/WICG/intrinsicsize-attribute/issues/16.

Flags: needinfo?(emilio)
You need to log in before you can comment on or make changes to this bug.