Closed Bug 1565714 Opened Last month Closed Last month

Disabled breakpoint numbers should be a shade of blue

Categories

(DevTools :: Debugger, enhancement, P3)

enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: jlast, Assigned: shellyc23)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files, 1 obsolete file)

We try and polish every detail of breakpoints down to the color of the breakpoint line number text color. One case we do not handle well is disabled breakpoints, which are the active line number grey. We should update it to be a blue that is darker than disabled breakpoints, which will be slightly more refined.

Keywords: good-first-bug
Priority: -- → P3
Attached image 2019-07-14-11-44-32.png

I would like to try my hand at this.

I noticed when disabling breakpoints, they appear white though.

In Breakpoint.js I added an if else statement to the function addBreakpoint() to add/remove class "breakpoint-disabled" depending on the value of breakpoint.disabled. I then added a selector in Editor.css to set color: blue.

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56582e290c63
Disabled breakpoint numbers should be a shade of blue
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Assignee: nobody → shellyc23
Duplicate of this bug: 1565711
Duplicate of this bug: 1565713
Regressions: 1571582
Attachment #9078027 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.