Closed Bug 1565796 Opened 5 months ago Closed 5 months ago

Poor text rendering with webrender

Categories

(Core :: Graphics: WebRender, defect)

68 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox68 --- affected

People

(Reporter: katzelad, Unassigned)

References

Details

Attachments

(1 file)

Attached image webrender.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Browse the web with webrender on (by default) since the upgrade to FF 68 (I had webrender on in FF 67 with no issues).
Windows 10, GTX 960, 1080p.

Actual results:

The text looks bad, with inconsistent spacing between letters and occasional blur (left side in the attached screenshot).

Expected results:

The text looks normal with webrender disabled (gfx.webrender.force-disabled=true, right side in the attached screenshot).

Component: Untriaged → Graphics: WebRender
Product: Firefox → Core
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Is it possible for you to get regression window using mozregression? https://mozilla.github.io/mozregression/

Flags: needinfo?(katzelad)

I managed to solve the issue by reseting both gfx.content.azure.backends and gfx.canvas.azure.backends to the default value of direct2d1.1,skia,cairo instead of direct2d1.1,cairo,skia which I had set for some reason (an old profile).

Flags: needinfo?(katzelad)

Thank you for finding the cause! This has been fixed for Firefox 69.

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Depends on: 1559810
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.