Closed Bug 1565809 Opened 1 year ago Closed 11 days ago

Some tiles suddenly became transparent, contained single, broken characters (picture-caching)

Categories

(Core :: Graphics: WebRender, defect, P3)

70 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox68 --- unaffected
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- fixed

People

(Reporter: darkspirit, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: correctness, nightly-community, regression, Whiteboard: [sci-exclude])

Attachments

(10 files)

Nightly 20190713095401, KDE, X11, Debian Testing, Macbook Pro A1502, Intel Iris 6100 (Broadwell GT3)

  • This problem happened randomly, so I can't run with MOZ_GTK_TITLEBAR_DECORATION=none to check if it's a duplicate of bug 1518796. But at the moment it seems unlikely to be a duplicate because transparent tiles of the attached screenshot even contain single, broken characters and purple arrows. Transparent tiles scrolled with the page and became fixed when hovering them.
  • This looks rather related to bug 1562462 comment 14.
  • Resolution of bug 1565297 is correct, it was perfectly reproducible and is now fixed.
  • Next time I'll provide a WR capture, Ctrl + # works ...
Blocks: wr-69
Priority: -- → P3

It went away as suddenly as it appeared.

  • No broken tiles, but missing, broken and wrong characters.
  • There should be a grey arrow (made with borders) in the bottom left corner of the box.
  • Round bottom-right border of the box is corrupted.
  • Blue speaker symbol is a div with background-image: url(data:image/svg+xml: Its lower half is missing.
  • Account and app menu symbols are missing in the top-right corner.
  • I had totally forgotten to make a capture...

Three days ago, window buttons disappeared when I hovered a tab, and reappeared after moving the mouse somewhere else.

20190731215544, KDE (but without compositor), X11, Debian Testing, Macbook Pro A1502, Intel Iris 6100 (Broadwell GT3)
It happened right after clicking on Start Debug Mode on about:webrtc and was gone after making the screenshot.

  • The active tab has lost its text. Also "Clear Log" is gone from the still visible button on the left black tile.
  • Gone: My account icon (between uBlock Origin and the overflow icon) is an orange dogefox.
Attached image amazon_broken.png
Attachment #9082619 - Attachment description: amazon_correct.png → amazon_almost_correct.png
Attachment #9082619 - Attachment filename: amazon_correct.png → amazon_almost_correct.png

Likely impossible. I can only assume this was caused by bug 1558106. bug 1562462 only circumvented this bug on Windows.
I didn't withhold any occurrence. It really happens only so rarely.

Hi,

I'm trying to do the regression but this looks like a very random bug. I've been trying to reproduce it on a Ubuntu 18.04.2 x86-64 but with no luck. Do you have specific sure-to-success steps to reproduce it?

Best regards, Flor.

Flags: needinfo?(jan)

Sorry. I left comment 6 to prevent this question. ^^ STR is unfortunately "suddenly". I'll add more info when I know more.

Has STR: --- → no
Flags: needinfo?(jan)
Summary: Some tiles suddenly became transparent, contained single, broken characters → Some tiles suddenly became transparent, contained single, broken characters (picture-caching)
Whiteboard: [sci-exclude]
Blocks: wr-70
No longer blocks: wr-69

Jan, have you seen this again recently?

Flags: needinfo?(jan)

Last week or the week before I've seen one black tile like in comment 3.

Flags: needinfo?(jan)

Build 20191001041624. It happened after scrolling down. And the table doesn't contain anything blue, those pixels are garbage.

Flags: needinfo?(gwatson)

Darkspirit, can you reliably reproduce this on the site you shared a screenshot of?

Flags: needinfo?(jan)

Of course not. Still the same as comment 8. Such a hiccup happens every few days, unrelated to a specific website.

Flags: needinfo?(jan)

(These happened after bug 1585240. I don't know if it could have influenced things.)
Here, I have saw the same general bug yesterday and today, but with different colors. Of course everything was fixed by hovering those tiles.

(some tiles fixed by hovering them)

(today it was blue instead of yellow)

I've never seen this occur. I develop on KDE + X11, but with a somewhat different hardware setup (an XPS laptop with HD620 GPU).

A couple of options we could try, if Jan would be willing to:

  1. I could provide a special build that has extra OpenGL logging enabled. This might allow us to see if any GL errors are occurring when the bug happens.

  2. I could write up a set of steps describing how to run Firefox under apitrace. This allows us to trace all OpenGL calls and replay them later on another machine. This might give us a good insight into what's occurring if we can get a trace file when it happens. The downsides of this method are privacy (we'd be able to exactly reply every single frame that Firefox drew during the trace), the browsing will be slower, and the trace files can get very large (so possibly only useful if we get a capture where the bug occurs relatively soon after starting the browser).

It's also possible (perhaps likely) that this is a driver bug and neither (1) or (2) would help.

Another thing that would be helpful is seeing the output of glxinfo so we can see what version of mesa etc is in use.

Flags: needinfo?(gwatson)
Attached file glxinfo.txt

It usually happens after longer usage (30m to 3h). Totally random, I have no clue yet. It doesn't seem directly related to Firefox media playback or VLC media player, nor to opening tabs. It can also occur just while looking at a page without any interaction, without touching the touchpad.
The only unusual pref I basically always had is gfx.webrender.program-binary-disk;true. Turned it off now.

Rolling release distro:
https://packages.debian.org/testing/libglx-mesa0 (currently: 19.1.6-1)
https://wiki.debian.org/DebianTesting

Blocks: wr-71
No longer blocks: wr-70
Blocks: wr-72
No longer blocks: wr-71
See Also: → 1599716

darkspirit, have you been able to get a capture of this recently?

Flags: needinfo?(jan)
Blocks: wr-wild
No longer blocks: wr-72

Hm, I definitely haven't seen this problem in the last 14 days:
I have enabled gfx.webrender.panic-on-gl-error since it was implemented (bug 1604625) and did not notice a "significant performance impact". about:crashes only contains my Fission bugs, so I guess I should have an eye on about:support and report back if I see something there.

Strange. It must have been fixed in the last month?

Status: NEW → RESOLVED
Closed: 11 days ago
Flags: needinfo?(jan)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.