Closed Bug 1566200 Opened 3 months ago Closed 3 months ago

Various search engines are using the wrong encoding for search parameters after switch to WebExtensions

Categories

(Thunderbird :: Search, defect)

Desktop
Windows 10
defect
Not set

Tracking

(thunderbird_esr60 unaffected, thunderbird67 unaffected, thunderbird68 fixed, thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird67 --- unaffected
thunderbird68 --- fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: alice0775, Assigned: jorgk)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1565779 +++

Reproducible : always

Steps to Reproduce:

  1. Set default search engine to ヤフオク! or 楽天市場
  2. Select Japanese text in email e.g,"パソコン"
  3. Right click ヤフオク!で検索 or 楽天市場で検索

Actual results:
Unable search in Japanese text due to Mojibake in Default Browser

Expected Results:
Search should successfully perform in Default Browser

Regression window:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=1ce8576d29ec4e7ec92faec84b082ff59e18f0a8&tochange=ddfc8b3514165e69dbf83fdb4b7928555268f49a
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b5bcfc2617667e3fc7a095b262b80377b2542446&tochange=a17f163841e956c10eb74cdbe27d7073facf6b7f

Regressed by: Bug 1544013 and Bug 1496075

Thanks. No problem porting the patch from bug 1565779.

Assignee: nobody → jorgk

Same patch as in bug 1565779.

Attachment #9078252 - Flags: review+
Attachment #9078252 - Flags: approval-comm-beta+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/e2fb0ea027df
Port bug 1565779: Add encoding to non-UTF-8 engines. r=me

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0

Looks like the patch from bug 1565779 didn't work :-(

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ba54e80a5691
Follow-up: Move encoding definitions to the correct location in the search engine manifest files. r=me DONTBUILD

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.