Closed Bug 1566364 Opened 4 months ago Closed 4 months ago

Redirect histogram accumulation calls for streaming telemetry in GeckoView

Categories

(Toolkit :: Telemetry, task, P1)

task

Tracking

()

RESOLVED DUPLICATE of bug 1566366
Tracking Status
firefox70 --- affected

People

(Reporter: Dexter, Assigned: chutten)

References

(Blocks 1 open bug)

Details

As per our proposal, this bug is for redirecting histogram accumulation calls, for metrics tagged as 'geckoview_streaming', when the (toolkit.telemetry.?)geckoview.streaming_telemetry is true.

The calls need to be redirected to the new GeckoView API.

Blocks: 1566340
See Also: → 1566366

This doesn't necessarily need to block on bug 1566366: a first implementation could be to have the whole thing working end-to-end, and then add the batching.

Depends on: 1566367
Assignee: nobody → chutten
Status: NEW → ASSIGNED
Priority: -- → P1

I'll fold this work into bug 1566366

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1566366
You need to log in before you can comment on or make changes to this bug.