Closed Bug 1566376 Opened 5 months ago Closed 3 months ago

Enable the GeckoView/Glean integration in Fenix

Categories

(Data Platform and Tools :: Glean: SDK, task, P1)

task

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Dexter, Assigned: Dexter)

References

(Blocks 1 open bug)

Details

(Whiteboard: [telemetry:glean-rs:m8] [geckoview:fenix:m8])

Attachments

(1 file)

This bug is for enabling fetching GeckoView metrics, in Fenix, using the Glean SDK.

See the proposal for more details.

Blocks: 1566340
Depends on: 1566374
Priority: -- → P3
Whiteboard: [telemetry:glean-rs:m?]
Depends on: 1564989
Whiteboard: [telemetry:glean-rs:m?] → [telemetry:glean-rs:backlog][geckoview]
Depends on: 1568485
Whiteboard: [telemetry:glean-rs:backlog][geckoview] → [telemetry:glean-rs:backlog] [geckoview:fenix:m8]
Duplicate of this bug: 1497812
Blocks: 1573475

I just found that Fenix Nightly is not using engine-gecko-nightly but, rather, engine-gecko-beta (GV 69).

This means that, in order to enable the mechanism on Fenix, we need to uplift to Beta. This makes testing the system a bit risky. For this reason I filed bug 1573475 to do the testing in the &-browser. Once we're ok with the behaviour of this mechanism, we can uplift to beta 69.

Note: there's a WIP PR in Fenix to make Fenix Nightly use GeckoView Nightly.

Assignee: nobody → alessio.placitelli
Priority: P3 → P1
Attached file GitHub Pull Request
Whiteboard: [telemetry:glean-rs:backlog] [geckoview:fenix:m8] → [telemetry:glean-rs:m8] [geckoview:fenix:m8]
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.