Closed Bug 1566559 Opened 1 year ago Closed 7 months ago

Fission: Restored page from session restore with custom zoom resets to default

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1612068
Fission Milestone M6
Tracking Status
firefox70 --- disabled

People

(Reporter: yoasif, Assigned: emilio)

References

(Blocks 3 open bugs)

Details

(Keywords: access, nightly-community)

Not sure if this is the right component, please change if incorrect.

Steps to reproduce:

  1. Enable Fission
  2. Enable session restore
  3. Navigate to https://news.ycombinator.com
  4. Zoom page to 133%
  5. Open a new tab, navigate to any page.
  6. Quit Firefox
  7. Open Firefox
  8. Switch to the https://news.ycombinator.com tab from your restored session

What happens:

The zoom level shows as 133% in the address bar, but the page content is 100%

Expected result:

Page is restored with 133% zoom.

Fission Milestone: --- → ?
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Fission Milestone: ? → M5

Moving to Layout as this is an issue with reflowing zoom.

Component: Panning and Zooming → Layout
Priority: -- → P3

I can't reproduce this any more, so going to assume a duplicate of 1567723.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1567723

I am still seeing this issue on Firefox Nightly with Fission enabled.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 1598191
Flags: needinfo?(jwatt)

I can confirm this bug in latest Nightly 73.0a1.
It only happens when Fission is enabled.
And it happens with most of the web-pages having a customized zoom (different from 100%).
By the way, I test this bug once a month, and never was solved.

Botond, any idea where I could start investigating this?

Flags: needinfo?(botond)

I'm not sure off the top of my head. Reflowing zoom is a layout feature that doesn't have anything to do with APZ, and I haven't had much interaction with it beyond calling nsPresContext::AppUnitsPerDevPixel() and similar functions to account for it during coordinate transformations.

A starting point to investigating this might be how the value that this function returns (nsPresContext::mCurAppUnitsPerDevPixel) is propagated to child content processes with Fission, or how it is remembered across a session restore.

Also cc'ing Morgan who implemented an enhancement to reflowing zoom recently, in case she might have more specific suggestions.

Flags: needinfo?(botond)
Keywords: access

Nika says this bug will probably get fixed as part of Alphan's work on Fission session restore (bug 1507287). Session restore is not process switch aware so the restored zoom level can be set in the wrong process.

We should add a test for this!

Tracking for Fission Nightly (M6) because restoring zoom level doesn't need to block internal dogfooding.

Blocks: 1507287
Fission Milestone: M5 → M6

(In reply to Chris Peterson [:cpeterson] from comment #9)

Nika says this bug will probably get fixed as part of Alphan's work on Fission session restore (bug 1507287). Session restore is not process switch aware so the restored zoom level can be set in the wrong process.

We should add a test for this!

Tracking for Fission Nightly (M6) because restoring zoom level doesn't need to block internal dogfooding.

do you know how/if that work relates to this bug here? https://bugzilla.mozilla.org/show_bug.cgi?id=1612068
its been on my back burner, but if those zoom values are getting propagated somehow, I don't wanna touch them in this patch before that becomes true :)

Flags: needinfo?(cpeterson)

(In reply to Morgan Reschenberg [:morgan] from comment #10)

(In reply to Chris Peterson [:cpeterson] from comment #9)

Nika says this bug will probably get fixed as part of Alphan's work on Fission session restore (bug 1507287). Session restore is not process switch aware so the restored zoom level can be set in the wrong process.

do you know how/if that work relates to this bug here? https://bugzilla.mozilla.org/show_bug.cgi?id=1612068
its been on my back burner, but if those zoom values are getting propagated somehow, I don't wanna touch them in this patch before that becomes true :)

Nika, is this session restore zoom bug possibly a duplicate of delay-loaded iframe zoom bug 1612068?

Flags: needinfo?(cpeterson) → needinfo?(nika)
See Also: → 1612068
Blocks: 1612068
See Also: 1612068
No longer blocks: 1612068
Assignee: nobody → emilio
Depends on: 1631776

Seems to work on the latest nightly, but please reopen / ni? if it doesn't work for you.

Status: REOPENED → RESOLVED
Closed: 1 year ago7 months ago
Flags: needinfo?(nika)
Flags: needinfo?(jwatt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1631776
Duplicate of bug: 1612068
You need to log in before you can comment on or make changes to this bug.