Closed Bug 1567198 Opened 2 months ago Closed 2 months ago

Create UA override for corporate.santander.co.uk

Categories

(Web Compatibility :: Interventions, enhancement, P1)

enhancement

Tracking

(firefox-esr60 unaffected, firefox-esr6869+ fixed, firefox68+ fixed, firefox69+ fixed, firefox70+ fixed)

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 69+ fixed
firefox68 + fixed
firefox69 + fixed
firefox70 + fixed

People

(Reporter: miketaylr, Assigned: ksenia)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

See https://bugzilla.mozilla.org/show_bug.cgi?id=1563839#c22

We already missed the boat for the 68.0.1 dot release, but it's possible we could ride along a 0.2 dot release. Getting uplift to Beta should be pretty simple.

Ksenia, can you take this one? We probably want just a single update to the addon (without any other interventions) that we can request uplifts for. Thanks.

Assignee: nobody → kberezina
Flags: needinfo?(kberezina)
Priority: -- → P1

My bad, the problem URL is on their co.uk site: https://corporate.santander.co.uk/

I'm also trying to get other relevant hosts from participants in this thread: https://support.mozilla.org/questions/1264370

Thank you, much appreciated jscher2000.

(It might be good to wait a day or so before landing, in case we identify any new subdomains.)

Flags: needinfo?(kberezina)
Summary: Create UA override for corporate.santanderbank.com → Create UA override for corporate.santander.co.uk

I've looked through the messages on https://support.mozilla.org/questions/1264370 and looks like no other domains are reported. jscher2000, do you think we should land the fix?

Flags: needinfo?(jscher2000)

We just had this one posted: retail.santander.co.uk

Flags: needinfo?(jscher2000)

Thanks. I'm unable to get to similar forms/inputs on https://retail.santander.co.uk/ without logging in. But I can add this domain anyways.

[Tracking Requested - why for this release]:
This is a sibling of bug 1563839.

Keywords: checkin-needed

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/a422af278049
create UA override for corporate.santander.co.uk r=denschub,rhelmer

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Please nominate this for Beta and ESR68 approval when you get a chance. That said, I wouldn't bank on there being a 68.0.2 release at this point as we don't have any obvious drivers for one. Might be worth putting together a system addon update that we can ship out of band for Fx68 users.

Comment on attachment 9079069 [details]
Bug 1567198 - create UA override for corporate.santander.co.uk

Beta/Release Uplift Approval Request

  • User impact if declined: The form looks broken in Firefox.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk because it's scoped to a single domain.
  • String changes made/needed:

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration:
  • User impact if declined: The form looks broken in Firefox.
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk because it's scoped to a single domain.
  • String or UUID changes made by this patch:
Flags: needinfo?(kberezina)
Attachment #9079069 - Flags: approval-mozilla-esr68?
Attachment #9079069 - Flags: approval-mozilla-beta?

Might be worth putting together a system addon update that we can ship out of band for Fx68 users.

Talking with Adam Stevenson, we think this one is OK to just ride from Beta to Release (given bug 1565673)

OK, sounds like we're going to let this patch just ride out with 69 then.

Comment on attachment 9079069 [details]
Bug 1567198 - create UA override for corporate.santander.co.uk

Adds a workaround for broken forms on a Santander site. Approved for 69.0b8 and 68.1esr.

Attachment #9079069 - Flags: approval-mozilla-esr68?
Attachment #9079069 - Flags: approval-mozilla-esr68+
Attachment #9079069 - Flags: approval-mozilla-beta?
Attachment #9079069 - Flags: approval-mozilla-beta+

Comment on attachment 9079069 [details]
Bug 1567198 - create UA override for corporate.santander.co.uk

Nominating just in case there's a 68.0.2 dot release driver, so we can ride along.

Attachment #9079069 - Flags: approval-mozilla-release?

Comment on attachment 9079069 [details]
Bug 1567198 - create UA override for corporate.santander.co.uk

Follow-up fix to an intervention we shipped in 68.0.1. We're already serving up a newer version of this SAO to users via balrog, but let's at least get this landed on m-r in the mean time.

Attachment #9079069 - Flags: approval-mozilla-release? → approval-mozilla-release+

FIREFOX_ESR_68_0_X_RELBRANCH: https://hg.mozilla.org/releases/mozilla-esr68/rev/6faf4772888d (to fix uplift conflict with bug 1568636)

You need to log in before you can comment on or make changes to this bug.