Closed Bug 1563839 Opened 2 months ago Closed 2 months ago

Create UA override for rolb.santanderbank.com for all platforms

Categories

(Web Compatibility :: Interventions, task, P1)

Tracking

(firefox-esr6868+ fixed, firefox68 fixed, firefox69 fixed, firefox70 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr68 68+ fixed
firefox68 --- fixed
firefox69 --- fixed
firefox70 --- fixed

People

(Reporter: ehsan, Assigned: ksenia)

References

Details

Attachments

(1 file, 1 obsolete file)

The required UA override needs to apply on all platforms. It needs to modify the default UA string to replace "Gecko" with "like Gecko". I would imagine it would include code like:

  uaTransformer: (originalUA) => {
    return originalUA.replace("Gecko", "like Gecko");
  }

Ksenia, can you work on this please?

Assignee: nobody → kberezina
Priority: -- → P1

And the patch just needs to apply to https://rolb.santanderbank.com, yes? (or do we possibly need/want to target it more accurately to a specific landing like https://rolb.santanderbank.com/FORPAS_ENS/ChannelDriver.ssobto?)

Flags: needinfo?(ehsan)

(In reply to Thomas Wisniewski [:twisniewski] from comment #2)

And the patch just needs to apply to https://rolb.santanderbank.com, yes? (or do we possibly need/want to target it more accurately to a specific landing like https://rolb.santanderbank.com/FORPAS_ENS/ChannelDriver.ssobto?)

I don't know how to answer this question to be honest, I think answering it accurately requires information that I do not possess. Based on comment 3 it appears like the issue applies to more than just the URL in comment 2. It can really affect any page that includes https://rolb.santanderbank.com/Estatico/Globales/V74/Scripts/jsDomM.bjs. That is why I suggested the entire origin, but I cannot be sure if that's enough nor sufficient...

Flags: needinfo?(ehsan)

That's fine. It sounds like Ksenia found out that we'll have to go with the full domain a comment ago.

Sounds great to me!

Keywords: checkin-needed
Keywords: checkin-needed
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/139206811f54
add UA for rolb.santanderbank.com r=twisniewski,rhelmer

Note here: spoke with Relman, and they think we can get this out faster via a (planned) dot release ridealong. We're gonna test if patches apply cleanly then request uplifts.

Comment on attachment 9076870 [details]
Bug 1563839 - add UA for rolb.santanderbank.com

Beta/Release Uplift Approval Request

  • User impact if declined: The form looks broken in Firefox.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk because it's scoped to a single domain.
  • String changes made/needed: None
Attachment #9076870 - Flags: approval-mozilla-beta?

(we're still figuring out if we can gofaster to release before the dot release -- will update here if so)

Duplicate of this bug: 1561036

Comment on attachment 9076870 [details]
Bug 1563839 - add UA for rolb.santanderbank.com

Adds a UA override to broken feature detection on a site. Approved for 69.0b4.

Attachment #9076870 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9076870 [details]
Bug 1563839 - add UA for rolb.santanderbank.com

Requesting release uplift and dot-release ridealong. In the course of testing Bug 1564974 (our balrog SAO update bug), Dennis discovered Bug 1565673.

If we get release uplift, we won't break about:compat -- I've already tested in Beta. Risk should be minimal as before, PI already tested it.

Attachment #9076870 - Flags: approval-mozilla-release?

Comment on attachment 9076870 [details]
Bug 1563839 - add UA for rolb.santanderbank.com

approved for 68.0.1 (desktop) and 68.1esr (desktop+fennec)

Attachment #9076870 - Flags: approval-mozilla-release?
Attachment #9076870 - Flags: approval-mozilla-release+
Attachment #9076870 - Flags: approval-mozilla-esr68+

Per discussion with jcristau, we're uplifting this to 68.0.1esr also to maintain parity with the non-ESR 68.0.1 release and hopefully avoid some confusion.

Can "://corporate.santanderbank.co.uk/" be added to this patch or does a new bug need to be filed?

https://github.com/webcompat/web-bugs/issues/35386

(In reply to jscher2000 from comment #22)

Can "://corporate.santanderbank.co.uk/" be added to this patch or does a new bug need to be filed?

https://github.com/webcompat/web-bugs/issues/35386

Aw shucks. :/ We would need to file a new bug -- these patches have already landed.

I called the bank today specifically referencing this bug id -- I have an account with these guys. Hope they make a move here. I also saw that on their site that they say:

We are aware that some customers are having application issues when using Firefox v68. For the best experience, please use an alternative browser.

Hoping that they actually fix this instead of posting this notice on their site.

You need to log in before you can comment on or make changes to this bug.