Closed Bug 1567624 Opened 2 months ago Closed Last month

Can't close Page Info window with Ctrl+w

Categories

(Firefox :: Page Info Window, defect, P3)

67 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- verified
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- verified

People

(Reporter: yoasif, Assigned: jaws)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

  1. Open Page Info window
  2. Do ctrl+w shortcut

What happens:

Nothing

Expected result:

Window closes.

13:34.20 INFO: No more inbound revisions, bisection finished.
13:34.20 INFO: Last good revision: 0a4aefb36aff504e179121c8de0039c0df9e8106
13:34.20 INFO: First bad revision: 03aece6cda47ff158485d986e19ba230ea4c8834
13:34.20 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0a4aefb36aff504e179121c8de0039c0df9e8106&tochange=03aece6cda47ff158485d986e19ba230ea4c8834

Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Regressed by: 1517493

Chris Frey, Your patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(freychr3)
Component: General → Page Info Window

Adding needinfo on Jared who participated in bug 1517493.

Flags: needinfo?(jaws)
Priority: -- → P3
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Flags: needinfo?(freychr3)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ecbdc21c19e6
Fix key of cmd_close command, and add data-l10n-attrs so the 'key' attribute is allowed to be set from Fluent. r=florian,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Are these kind of FTL changes an issue for localizers if we wanted to uplift this?

Flags: needinfo?(francesco.lodolo)

(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)

Are these kind of FTL changes an issue for localizers if we wanted to uplift this?

I can't provide a blanket statement about it.

In general, keyboard shortcuts should not be localized, but there can be exceptions due to keyboard layouts.

Uplifting this specific one would be possible, since we fall back to English, and it's a common letter. The only annoying part is that, suddenly, your beta translation might be missing a string, but I wouldn't worry too much about it.

Flags: needinfo?(francesco.lodolo)

Comment on attachment 9083537 [details]
Bug 1567624 - Fix key of cmd_close command, and add data-l10n-attrs so the 'key' attribute is allowed to be set from Fluent. r?florian

Beta/Release Uplift Approval Request

  • User impact if declined: Pressing ctrl+w won't close Page Info.
    Given that this regression was already present in the 67 and 68 releases, it doesn't matter much if it takes another 6 weeks for the fix to reach users... but it's unfortunate for esr users. I don't care strongly about uplifting this fix, but comment 7 says it's possible.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open Page Info, try to close it using the Ctrl+w keyboard shortcut.
    Note: I couldn't reproduce this bug on Mac because the menubar made the shortcut work anyway. I would recommend testing on Windows.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk because it's a trivial change. But it's annoying that this contains a string...
  • String changes made/needed: yes.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This will be a new regression for users upgrading to esr68
  • User impact if declined:
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String or UUID changes made by this patch:
Attachment #9083537 - Flags: approval-mozilla-esr68?
Attachment #9083537 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9083537 [details]
Bug 1567624 - Fix key of cmd_close command, and add data-l10n-attrs so the 'key' attribute is allowed to be set from Fluent. r?florian

Based on the blessing of both Flod and Pike, approving this for 69.0b14 and 68.1esr.

Attachment #9083537 - Flags: approval-mozilla-esr68?
Attachment #9083537 - Flags: approval-mozilla-esr68+
Attachment #9083537 - Flags: approval-mozilla-beta?
Attachment #9083537 - Flags: approval-mozilla-beta+

Confirmed issue with 68.0.2 on Windows 10.
Fix verified with: esr68(task clusker build) 69.0b14, 70.0a1 (2019-08-15) on Windows 10, Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.