Closed Bug 1568373 Opened 6 months ago Closed 3 months ago

Picture in Picture should have a black background

Categories

(Toolkit :: Video/Audio Controls, defect, P5)

70 Branch
Desktop
All
defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: sdk, Assigned: dennisschagt)

Details

(Keywords: nightly-community)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

  1. Play a video in your browser
  2. Toggle on the Picture-in-Picture mode

Actual results:

On a system running a tiling window manager (e.g. i3wm or bspwm), a new window for PiP is opened in tiled mode. This means the window doesn't necessarily has the same dimension as the video inside it. The space not covered by the video is currently white.

Expected results:

The space not covered by the video should be black (e.g. like in VLC when the video dimension is different than the VLC window). This would reduce eyes strain.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit
OS: Unspecified → All
Hardware: Unspecified → Desktop

bug 1553835 already covers using a floating instead of tiling window in those circumstances. That seems like the appropriate solution here.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553835

(In reply to :Gijs (he/him) from comment #1)

bug 1553835 already covers using a floating instead of tiling window in those circumstances. That seems like the appropriate solution here.

I'm reopening the issue for now because:

In my use case, I want to use it in tiled mode to avoid the window to overlap other windows. Most of the time, I split my screen like 2/3 for browsing the Web and 1/3 for the PiP window.

Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

(IMHO) I don't think PiP is intended to be that large. If you want it that large, simply use YouTube in a second Firefox window. Or open https://www.youtube.com/embed/frzqXaaE62k to have the video even larger (in case embedding is allowed).

Hey sdk,

Out of curiosity, what do other browsers like Chrome and Opera do with their Picture-in-Picture player windows on tiled display managers?

Flags: needinfo?(contact)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #4)

Out of curiosity, what do other browsers like Chrome and Opera do with their Picture-in-Picture player windows on tiled display managers?

Chrome use a black background. I guess it's the same for Opera since it's based on Chromium.

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #3)

(IMHO) I don't think PiP is intended to be that large. If you want it that large, simply use YouTube in a second Firefox window. Or open https://www.youtube.com/embed/frzqXaaE62k to have the video even larger (in case embedding is allowed).

There's a performance hit in using a second window vs. PiP (200mb vs. 40mb with Youtube). Also, with PiP I get rid of the layout around the video. Some websites don't have a "Theater mode" à la Youtube.

Flags: needinfo?(contact)

This bug is still valid, in GNOME the PIP window is opened and is resizable through dragging the sides of the window (see attached screenshot).

Assignee: nobody → dennisschagt
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0676d719ecf8
Use black background for Picture-in-Picture window r=mconley
Status: ASSIGNED → RESOLVED
Closed: 6 months ago3 months ago
Resolution: --- → FIXED

The bug should be closed by the tree sheriffs when the patch lands to central.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.