Closed Bug 1568664 Opened 3 months ago Closed 3 months ago

Thunderbird Update Verify diff-summary.log broken link in Treeherder

Categories

(Thunderbird :: Build Config, defect, P2)

defect

Tracking

(thunderbird69 fixed, thunderbird70 fixed)

RESOLVED FIXED
Thunderbird 70.0
Tracking Status
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: rjl, Assigned: rjl)

Details

Attachments

(1 file)

Update Verify jobs fail to upload diff-summary.log to Taskcluster. This is resulting in broken links in Treeherder for these logs.

[taskcluster 2019-07-23 23:38:44.516Z] Artifact "public/build/diff-summary.log" not found at "/builds/worker/tools/release/updates/diff-summary.log"

Priority: -- → P2
Fix for broken link in Treeherder. Will make debugging problems
with UV jobs a lot easier.

Needs an uplift to 69 and 68.
Attachment #9080973 - Flags: review?(geoff)

If it needs uplift, please set the flags to some future release manager can take care of it. Most likely that person doesn't know the bug here.

Flags: needinfo?(rob)
Status: NEW → ASSIGNED
Flags: needinfo?(rob)
Keywords: checkin-needed
Keywords: checkin-needed
Comment on attachment 9080973 [details] [diff] [review]
diff-summary-fix.patch

[Approval Request Comment]
Regression caused by (bug #): No bug associated with FF commit. D32403 in Phabricator
User impact if declined: one
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):
Zero to none. This is a build config bug that really only affects me when I try to debug UV jobs that failed. Having the diff-summary available means I don't have to rerun it locally or scan the live.log
Attachment #9080973 - Flags: approval-comm-esr68?
Attachment #9080973 - Flags: approval-comm-beta?

Why do they do stuff like https://phabricator.services.mozilla.com/D32403 without filing a bug? How do they track uplifts? That's just a nightmare.

Attachment #9080973 - Flags: review?(geoff) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/368dfbc6dfae
Fix path to update-verify diff-summary log. r=darktrojan DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

I added this to the commit comment:
... and landed in
https://hg.mozilla.org/mozilla-central/rev/ebc58c182383d769cc609e6eb17dda547586d5ab

Note the landing date of Fri, 24 May 2019 on mozilla69.
https://hg.mozilla.org/releases/mozilla-esr68/rev/ebc58c182383d769cc609e6eb17dda547586d5ab

It is NOT on mozilla-esr68 as far as I can see:
https://searchfox.org/mozilla-esr68/search?q=diff-summary.log&case=true&regexp=false&path=

So why would it need uplift to comm-esr68? Please clear the flag if you agree.

Flags: needinfo?(rob)
Target Milestone: --- → Thunderbird 70.0
Comment on attachment 9080973 [details] [diff] [review]
diff-summary-fix.patch

You are correct. I was apparently getting my versions confused the other day.  Request for uplift to comm-esr68 withdrawn.
Flags: needinfo?(rob)
Attachment #9080973 - Flags: approval-comm-esr68?
Attachment #9080973 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.