Closed Bug 1568755 Opened 5 months ago Closed 21 days ago

Instrument gfx and perf environment metrics in engine-gecko-*

Categories

(Data Platform and Tools :: Glean: SDK, task, P3)

Unspecified
Android
task

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1594145

People

(Reporter: Dexter, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [telemetry:glean-rs:m10] [geckoview:p2])

In our GV+Glean proposal we decided to port a handful of metrics from the Desktop-only TelemetryEnvironment.jsm to engine-gecko-*, to be available in the Glean metrics ping.

A few options were floated around:

a. GV would expose a specific data structure through the TelemetryDelegate interface, such structure would contain read only fields to be consumed, using a pull model, by embedders (e.g. engine-gecko-)
b. the Telemetry+Glean teams would add support for scalars in GV+Glean; owners of the related fields in the TelemetryEnvironment would add geckoview_streaming only fields as Scalars; we'd exfiltrate them as we currently do for histograms;
c. engine-gecko-
code would use Android APIs to fetch the values; however this would result in some code duplication and some values would still not be available (e.g. is webrender used?)

This bug is for deciding how to do that.

Blocks: 1566340
Priority: -- → P3
Whiteboard: [telemetry:glean-rs:m?][geckoview]
Whiteboard: [telemetry:glean-rs:m?][geckoview] → [telemetry:glean-rs:m7][geckoview]

Adding [geckoview:fenix:m8] whiteboard tag because the Fenix team would like to report Gecko Glean metrics in Q3.

OS: Unspecified → Android
Whiteboard: [telemetry:glean-rs:m7][geckoview] → [telemetry:glean-rs:m7] [geckoview:fenix:m8]
Whiteboard: [telemetry:glean-rs:m7] [geckoview:fenix:m8] → [telemetry:glean-rs:m8] [geckoview:fenix:m8]

Hey Chris! This is for adding environment-like metrics to Gecko for them to show up in Fenix+Gecko data (from row 65 in the spreadsheet). These metrics should be instrumented by the teams requesting them. Is anyone working on this in other bugs?

Flags: needinfo?(cpeterson)

(In reply to Alessio Placitelli [:Dexter] from comment #2)

These metrics should be instrumented by the teams requesting them. Is anyone working on this in other bugs?

I think we wanted the Gfx and Perf teams to instrument the metrics they listed in that spreadsheet. I will check with those teams. Is there a good example bug they can study to see how to instrument an existing Gecko telemetry probe for Glean?

Flags: needinfo?(cpeterson) → needinfo?(alessio.placitelli)
Whiteboard: [telemetry:glean-rs:m8] [geckoview:fenix:m8] → [telemetry:glean-rs:m8] [geckoview:p2]

(In reply to Chris Peterson [:cpeterson] from comment #3)

(In reply to Alessio Placitelli [:Dexter] from comment #2)

These metrics should be instrumented by the teams requesting them. Is anyone working on this in other bugs?

I think we wanted the Gfx and Perf teams to instrument the metrics they listed in that spreadsheet. I will check with those teams. Is there a good example bug they can study to see how to instrument an existing Gecko telemetry probe for Glean?

I just noticed we did not have docs for adding scalars to geckoview streaming. I filed bug 1587706 and took it: the patch is already in review.

Flags: needinfo?(alessio.placitelli)

(In reply to Alessio Placitelli [:Dexter] from comment #2)

This is for adding environment-like metrics to Gecko for them to show up in Fenix+Gecko data (from row 65 in the spreadsheet). These metrics should be instrumented by the teams requesting them. Is anyone working on this in other bugs?

Hi Alessio, I have a few questions:

  • Are you asking here for the Graphics and Perf teams to now add their environment metrics to Glean? And these are the same thing as scalar metrics?

  • I see that the Graphics team already instrumented some of their streaming metrics from the spreadsheet to metrics.yaml (like COMPOSITE_TIME bug 1580129, for example). Should I reach out to other Gecko teams and ask them to start instrumenting their streaming and scalar metrics to be collected in GeckoView?

Flags: needinfo?(alessio.placitelli)

(In reply to Chris Peterson [:cpeterson] from comment #5)

(In reply to Alessio Placitelli [:Dexter] from comment #2)

This is for adding environment-like metrics to Gecko for them to show up in Fenix+Gecko data (from row 65 in the spreadsheet). These metrics should be instrumented by the teams requesting them. Is anyone working on this in other bugs?

Hi Alessio, I have a few questions:

  • Are you asking here for the Graphics and Perf teams to now add their environment metrics to Glean? And these are the same thing as scalar metrics?

To be precise: it's not adding their metrics to Glean, but adding them to Gecko so that Glean can expose them. Environment data from Desktop pings is just a bunch of scalar metrics that are not scalars yet. That's why we need teams to add Scalars. But we have docs for that, too, with an example.

We can help with some of these, but we cannot do them all, as we're not really domain experts there (ideally people who add metrics/own metrics should know about these metrics).

  • I see that the Graphics team already instrumented some of their streaming metrics from the spreadsheet to metrics.yaml (like COMPOSITE_TIME bug 1580129, for example). Should I reach out to other Gecko teams and ask them to start instrumenting their streaming and scalar metrics to be collected in GeckoView?

There's these bunch of scalars/environment that are GFX related (from the usual spreadsheet):

  • gfx_display_count
  • gfx_display_h
  • gfx_display_v
  • gfx_adapter
  • gfx_compositor
  • gfx_status_webrender
  • gfx_status_headless

It would be great if somebody from the GFX team could add the related scalars for them.

Flags: needinfo?(alessio.placitelli)

Jeff, I'm guessing I need to implement this before we can actually compare webrender vs non-webrender Fenix?

Whiteboard: [telemetry:glean-rs:m8] [geckoview:p2] → [telemetry:glean-rs:m10] [geckoview:p2]
Depends on: 1594145

This bug can be closed: the implementation work is happening as part of bug 1594145.

Status: NEW → RESOLVED
Closed: 21 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1594145
You need to log in before you can comment on or make changes to this bug.