Closed Bug 1594145 Opened 3 months ago Closed 2 months ago

Add gfx telemetry scalars to geckoview_streaming

Categories

(Core :: Graphics: WebRender, task, P3)

All
Unspecified
task

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: ktaeleman, Assigned: ktaeleman)

References

Details

Attachments

(2 files)

Priority: -- → P3
Hardware: Unspecified → All
Assignee: nobody → ktaeleman
Attachment #9108587 - Attachment filename: pasted.txt → pasted.md
Attachment #9108587 - Attachment mime type: text/plain → text/markdown
Attachment #9108587 - Attachment mime type: text/markdown → text/plain

@chutten: can you review the data collection form? Thanks!

Flags: needinfo?(chutten)
Comment on attachment 9108587 [details]
Data Collection review form

PRELIMINARY NOTES:
Please use the `data-review` flag for the attachment and include the Data Steward you'd like to request review from. That way it shows up where I expect : )

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is Telemetry sent via the Glean SDK so is documented in its definitions files [Scalars.yaml](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Scalars.yaml) and [metrics.yaml](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/geckoview/streaming/metrics.yaml). The Scalars are further documented in the [Probe Dictionary](https://telemetry.mozilla.org/probe-dictionary/), and the Glean SDK metrics are further documented in [engine-gecko-nightly's repository](https://github.com/mozilla-mobile/android-components/blob/master/components/browser/engine-gecko-nightly/docs/metrics.md).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences. (including on Fenix)

    If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Kris Taeleman is responsible.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

No. This collection is permanent.

---
Result: datareview+
Flags: needinfo?(chutten)
Attachment #9108587 - Flags: data-review+
Duplicate of this bug: 1568755
Pushed by jnicol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ae41aa8997b
Add gfx telemetry scalars to geckoview_streaming. r=Dexter,jnicol
Pushed by jnicol@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/270e007adcd2
Add gfx telemetry scalars to geckoview_streaming. r=Dexter,jnicol

Backed out changeset 270e007adcd2 (Bug 1594145) for causing browser-chrome failures in browser_Troubleshoot.js

Backout link: https://hg.mozilla.org/integration/autoland/rev/cc3914c82cdad29dd4f3f7319ef248c2d472bc8c

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&collapsedPushes=598800&searchStr=%28bc&fromchange=d8c50a4827b20dd373175b16dcef35511a973a2a&group_state=expanded&tochange=b4755981c1382cb88fed4e4fcff3ba73779b2080&selectedJob=277994833

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=277994833&repo=autoland&lineNumber=24591

[task 2019-11-25T12:33:47.155Z] 12:33:47 INFO - TEST-UNEXPECTED-FAIL | toolkit/modules/tests/browser/browser_Troubleshoot.js | Schema mismatch, Error: Validation error: Object is not of the expected type: object=7688, schema={"type":"string"} -
[task 2019-11-25T12:33:47.155Z] 12:33:47 INFO - Stack trace:
[task 2019-11-25T12:33:47.155Z] 12:33:47 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2019-11-25T12:33:47.156Z] 12:33:47 INFO - chrome://mochitests/content/browser/toolkit/modules/tests/browser/browser_Troubleshoot.js:snapshotSchema/<:41

Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91f3048cc58e
Add gfx telemetry scalars to geckoview_streaming. r=Dexter,jnicol

Backed out changeset 91f3048cc58e (bug 1594145) for browser-chrome failures at toolkit/modules/tests/browser/browser_Troubleshoot.js

Backout: https://hg.mozilla.org/integration/autoland/rev/aa65436be9aff44e092986220901ad3b549e215c

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=91f3048cc58ea92aaf37b26267f9361e1c7ee74b

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=278145341&repo=autoland&lineNumber=50518

task 2019-11-26T02:34:02.802Z] 02:34:02 INFO - TEST-START | toolkit/modules/tests/browser/browser_Troubleshoot.js
[task 2019-11-26T02:34:02.942Z] 02:34:02 INFO - GECKO(3380) | JavaScript warning: resource://gre/modules/Troubleshoot.jsm, line 582: Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting.
[task 2019-11-26T02:34:02.942Z] 02:34:02 INFO - GECKO(3380) | Initializing context 0000022DCD77D000 surface 0000022DCDBC8A60 on display 0000022DCB6AE400
[task 2019-11-26T02:34:02.942Z] 02:34:02 INFO - GECKO(3380) | [Parent 8668, Main Thread] WARNING: framebuffer_multisample marked as unsupported: file z:/build/build/src/gfx/gl/GLContextFeatures.cpp, line 623
[task 2019-11-26T02:34:03.001Z] 02:34:03 INFO - GECKO(3380) | WebGL(0000022DCE1CC800)::ForceLoseContext
[task 2019-11-26T02:34:03.001Z] 02:34:03 INFO - GECKO(3380) | Destroying context 0000022DCD77D000 surface 0000022DCDBC8A60 on display 0000022DCB6AE400
[task 2019-11-26T02:34:03.001Z] 02:34:03 INFO - GECKO(3380) | JavaScript warning: resource://gre/modules/Troubleshoot.jsm, line 582: Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting.
[task 2019-11-26T02:34:03.001Z] 02:34:03 INFO - GECKO(3380) | JavaScript warning: resource://gre/modules/Troubleshoot.jsm, line 582: Error: WebGL warning: <SetDimensions>: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR
[task 2019-11-26T02:34:03.011Z] 02:34:03 INFO - GECKO(3380) | JavaScript warning: resource://gre/modules/Troubleshoot.jsm, line 582: Error: WebGL warning: <SetDimensions>: Failed to create WebGL context: WebGL creation failed:
[task 2019-11-26T02:34:03.011Z] 02:34:03 INFO - GECKO(3380) | * Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR
[task 2019-11-26T02:34:03.245Z] 02:34:03 INFO - TEST-INFO | started process screenshot
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - TEST-INFO | screenshot: exit 0
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - Buffered messages logged at 02:34:03
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - Console message: [JavaScript Warning: "Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting." {file: "resource://gre/modules/Troubleshoot.jsm" line: 582}]
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - Console message: [JavaScript Warning: "Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting." {file: "resource://gre/modules/Troubleshoot.jsm" line: 582}]
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - Console message: [JavaScript Warning: "Error: WebGL warning: <SetDimensions>: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR" {file: "resource://gre/modules/Troubleshoot.jsm" line: 582}]
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - Console message: [JavaScript Warning: "Error: WebGL warning: <SetDimensions>: Failed to create WebGL context: WebGL creation failed:
[task 2019-11-26T02:34:03.304Z] 02:34:03 INFO - * Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR" {file: "resource://gre/modules/Troubleshoot.jsm" line: 582}]
[task 2019-11-26T02:34:03.305Z] 02:34:03 INFO - Buffered messages finished
[task 2019-11-26T02:34:03.305Z] 02:34:03 INFO - TEST-UNEXPECTED-FAIL | toolkit/modules/tests/browser/browser_Troubleshoot.js | Schema mismatch, Error: Validation error: Object is not of the expected type: object=0, schema={"type":"string"} -
[task 2019-11-26T02:34:03.305Z] 02:34:03 INFO - Stack trace:
[task 2019-11-26T02:34:03.305Z] 02:34:03 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2019-11-26T02:34:03.305Z] 02:34:03 INFO - chrome://mochitests/content/browser/toolkit/modules/tests/browser/browser_Troubleshoot.js:snapshotSchema/<:41

Pushed by ktaeleman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/255c59b00b33
Add gfx telemetry scalars to geckoview_streaming. r=Dexter,jnicol
Flags: needinfo?(ktaeleman)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.