Closed Bug 1568833 Opened 2 years ago Closed 3 months ago

Make the "screenshot node" inspector feature work with oop frames

Categories

(DevTools :: Inspector, task, P3)

task

Tracking

(Fission Milestone:M7, firefox86 fixed)

RESOLVED FIXED
86 Branch
Fission Milestone M7
Tracking Status
firefox86 --- fixed

People

(Reporter: pbro, Assigned: nchevobbe)

References

(Blocks 2 open bugs)

Details

(Whiteboard: dt-fission-m3-mvp)

Attachments

(2 files)

With Fission, it must still be possible to grab screenshots of single elements, even when they are in oop iframes, from the inspector's context menu.

Priority: P3 → P2
Whiteboard: dt-fission
Priority: P2 → P3
Whiteboard: dt-fission → dt-fission-reserve

Tracking Fission DevTools bugs for Fission Nightly (M6)

Fission Milestone: --- → M6

dt-fission-reserve bugs do not need to block Fission Nightly (M6).

Fission Milestone: M6 → ---
See Also: → 1648293
Whiteboard: dt-fission-reserve → dt-fission-reserve, dt-fission-m3-mvp

Tracking dt-fission-m3-mvp bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7
Whiteboard: dt-fission-reserve, dt-fission-m3-mvp → dt-fission-m3-mvp

Bulk move of all dt-fission-m3-mvp bugs to Fission MVP milestone.

Fission Milestone: M7 → MVP
See Also: → 1678483
Type: enhancement → task
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED

The waitUntilScreenshot wasn't waiting for a new screenshot to be taken, and
if a test took 2 screenshots, it would always return the first one. This is
fixed by managing an array of the downloads we already waited for.

The test was also assuming the dpr of the screen was always 1, which was making
the test fail when running on a machine with a higher dpr screen (e.g. a retina screen).
The assertion for the width and height are updated to take dpr into account.

Retrieve the target in which the selected node lives in order
to get the right screenshotFront.

There was already a test checking that taking a node in an iframe was working,
but it was a same-origin iframe.
We modify the test so it checks both same-origin and remote iframe.

Depends on D101437

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35d059b7f9da
[devtools] Fix helper_screenshot_node helper. r=jdescottes.
https://hg.mozilla.org/integration/autoland/rev/b78f6648ade5
[devtools] Make Screenshot Node context menu item fission-compatible. r=jdescottes.
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Duplicate of this bug: 1601231

This completed dt-fission-m3-mvp bug should have Fission Milestone M7 Beta.

Fission Milestone: MVP → M7
You need to log in before you can comment on or make changes to this bug.