Closed Bug 1560200 Opened 1 year ago Closed 1 year ago

Connect the markup-view to multiple processes in the browser toolbox

Categories

(DevTools :: Inspector, enhancement, P1)

enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: pbro, Assigned: yulia)

References

(Blocks 4 open bugs)

Details

(Whiteboard: dt-fission dt-fission-m1)

Attachments

(2 files)

Make the markup-view connect to multiple processes for Fission. This means mostly making it possible for the panel to connect to multiple WalkerFronts.

Assignee: nobody → pbrosset

This is just a rough wip based on Alex's work here: https://phabricator.services.mozilla.com/D4564

Priority: -- → P3
Blocks: 1568822
Blocks: 1568825
Blocks: 1568833
Blocks: 1568837
Blocks: 1568840
Blocks: 1568857
Blocks: 1568860
Blocks: 1568874
Blocks: 1568880
Depends on: 1569200
Duplicate of this bug: 1569200
Assignee: pbrosset → nobody
Priority: P3 → P2
Whiteboard: dt-fission
Duplicate of this bug: 1569200
Assignee: nobody → ystartsev
Status: NEW → ASSIGNED
Priority: P2 → P1
Pushed by ystartsev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9d87e7c3201d
Implement very basic markup view support traversing remote frames via resource api. r=ochameau,rcaliman
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Summary: Connect the markup-view to multiple processes → Connect the markup-view to multiple processes in the browser toolbox
Blocks: 1573777
See Also: → 1598026
Whiteboard: dt-fission → dt-fission dt-fission-m1
You need to log in before you can comment on or make changes to this bug.