Closed Bug 1569180 Opened 5 months ago Closed 5 months ago

URL Dropdown Menu renders underneath bookmark toolbar

Categories

(Firefox :: Address Bar, defect, P1)

70 Branch
Desktop
All
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.2 - Jul 22 - Aug 4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 + verified

People

(Reporter: eira.lindblad, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

Attached image Example

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

I typed in the address bar so that the suggestions dropdown menu showed up

Actual results:

The dropdown menu rendered behind the text of the bookmarks in bookmark toolbar.

Expected results:

The dropdown menu should have rendered above the bookmark text, and indeed any other browser element.

According to https://twitter.com/ValkyrieEira/status/1154745226780717057 this is with today's build 2017-07-26 (not available yet for my linux version in French so I don't know if the bug is platform specific yet). Bug 1551598 landed this morning and looks like a potential regressor.

I am seeing it on Linux as well, setting Platform to All.

5:35.88 INFO: Last good revision: 47e72c204ef61c34509e430c0976f4db680e384a
5:35.88 INFO: First bad revision: 580d975db59096011e93150a04856a15b9e8812d
5:35.88 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=47e72c204ef61c34509e430c0976f4db680e384a&tochange=580d975db59096011e93150a04856a15b9e8812d

Dao, it seems that your patch in Bug 1551598 caused this regression, could you have a look please? Thanks

Component: Untriaged → Address Bar
Flags: needinfo?(dao+bmo)
OS: Unspecified → All
Regressed by: 1551598
Hardware: Unspecified → Desktop
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 70.2 - Jul 22 - Aug 4
Points: --- → 2
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Duplicate of this bug: 1569195
See Also: 1551598
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f5caaa674b95
Set z-index on urlbar-results so it renders over the bookmkars toolbar. r=mak
Duplicate of this bug: 1569241
Duplicate of this bug: 1569158
Duplicate of this bug: 1569173
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Duplicate of this bug: 1569332
Duplicate of this bug: 1569358
Blocks: megabar

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 70.0a1 (2019-07-27), so I'm marking this bug as VERIFIED.
Thank you very much! \o/

Status: RESOLVED → VERIFIED
QA Contact: Virtual
You need to log in before you can comment on or make changes to this bug.