Closed Bug 1569345 Opened 5 months ago Closed 4 months ago

Some object-fit WPT tests need a fuzzy annotation (rather than fails)

Categories

(Core :: Layout, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: dholbert, Assigned: dholbert)

References

Details

Attachments

(1 file)

We have some object-fit-*-png-* WPT tests that are annotated as failing (on non-webrender) due to a fuzzy image-scaling issue. This is basically fine -- the tests are only expected to be pixel-perfect if they can get image-rendering: pixelated, which we don't yet support.

Since it's not too many pixels differing, we should just annotate these as fuzzy rather than failing, to better reflect reality & to get a bit more strictness.

Here's a Try run that shows the failures for object-fit-cover-png-001 and -002 (after I've removed their .ini files):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=38d8022f5b3470804452b32673095bd216aa862f

Another Try run, with a few more .ini files removed/tweaked, and with bespoke fuzzy annotations based on that ^^ run combined with a local ./mach wpt run in this directory:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ec1b7bcebb538399339e3246dec9c09168b5f6f0

(I anticipate that this run will have some orange due to differences between platforms.)

All of these tests current fail due to fuzzy upscaling/downscaling behavior,
which the tests aim to work around using image-rendering: pixelated, but we
don't yet support that feature. I've added the bug link for that feature to
these .ini files, so that we'll get a clue to remove these annotations once we
fix that bug and implement that feature.

Attachment #9082150 - Attachment description: Bug 1569345: Use more specific/strict annotations object-fit & object-position WPT tests. → Bug 1569345: Use more specific/strict annotations object-fit & object-position WPT tests. (no review, just adjusting WPT test annotations)
Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7103a15a90f
Use more specific/strict annotations object-fit & object-position WPT tests.
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Regressions: 1571335
You need to log in before you can comment on or make changes to this bug.