Closed Bug 1569478 Opened 4 months ago Closed 4 months ago

Empty white space below urlbar dropdown when one-off buttons are hidden after landing patch from bug #1551598

Categories

(Firefox :: Address Bar, defect, P2)

70 Branch
defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.2 - Jul 22 - Aug 4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: Virtual, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(6 keywords)

Attachments

(3 files)

Attached image bad.png

STR:

  1. Have only 1 active One-Click Search Engine in Search tab ( about:preferences#search ) in Options ( about:preferences )
  2. In Address Bar write "test"
    and see that there is more useless blank white space below urlbar dropdown in Address Bar after landing patch from bug #1551598

It's also not consistent with amount of blank white space above urlbar dropdown in Address Bar.

Regression caused by:
Bug #1551598 - Stop using a popup window for urlbar results. r=mak

Differential Revision:
https://phabricator.services.mozilla.com/D38988

Has Regression Range: --- → yes
Has STR: --- → yes

Hm, one-off buttons are not visible there, did you disable them through the about:config pref?

Flags: needinfo?(Virtual)
Regressed by: 1551598

See STR #1, as I have only 1 One-Click Search Engine, so there shouldn't be any buttons visible.

Flags: needinfo?(Virtual)
Summary: More useless blank white space below urlbar dropdown in Address Bar after landing patch from bug #1551598 → Empty white space below urlbar dropdown when one-off buttons are hidden
Priority: -- → P2
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 70.2 - Jul 22 - Aug 4
Points: --- → 1
OS: Windows 7 → All
Hardware: x86_64 → All
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ad0fb1caddd
Fix one-off search button hiding. r=mak
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Blocks: megabar

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 70.0a1 (2019-07-31), so I'm marking this bug as VERIFIED.
Thank you very much! \o/

Status: RESOLVED → VERIFIED
Summary: Empty white space below urlbar dropdown when one-off buttons are hidden → Empty white space below urlbar dropdown when one-off buttons are hidden after landing patch from bug #1551598
You need to log in before you can comment on or make changes to this bug.