Closed Bug 1569542 Opened 1 year ago Closed 1 year ago

Disable Content Blocking UI tour in 69 / 68 ESR

Categories

(Firefox :: Protections UI, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr68 --- verified
firefox68 --- wontfix
firefox69 --- verified
firefox70 --- unaffected

People

(Reporter: johannh, Assigned: johannh)

References

Details

Attachments

(1 file)

The UI tour for content blocking isn't really accurate when it comes to ETP anymore (we're not hiding any elements) and it's a minor annoyance to users that see the doorhanger and have to click it away. It was entirely removed in bug 1564367 but instead of uplifting that bug (to reduce risk), we decided to simply disable the tour for everyone via pref in 68 ESR and 69.

Comment on attachment 9081619 [details]
Bug 1569542 - Disable Content Blocking UI tour in 69 / 68 ESR. r=ewright

Beta/Release Uplift Approval Request

  • User impact if declined: Annoying and partially incorrect UI tour shown to a lot of users when we roll out ETP
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: With a fresh profile (or a profile that did not have ETP enabled, meaning any profile that doesn't have a custom value for browser.contentblocking.introCount), open any webpage with trackers, e.g. https://ebay.com
  • No intro panel / UI tour should be shown
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Flips a pref that disables the content blocking UI tour
  • String changes made/needed: None

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: I'm not sure about our plan to roll out ETP on ESR, but it's probably safer to disable the UI tour here as well.
  • User impact if declined: Annoying and partially incorrect UI tour shown to a lot of users when we roll out ETP
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Flips a pref that disables the content blocking UI tour
  • String or UUID changes made by this patch: None
Attachment #9081619 - Flags: approval-mozilla-esr68?
Attachment #9081619 - Flags: approval-mozilla-beta?
Flags: qe-verify+

This explicitly doesn't need to land on central, because we already removed the content blocking tour in bug 1564367. This is just for disabling on beta/ESR.

Comment on attachment 9081619 [details]
Bug 1569542 - Disable Content Blocking UI tour in 69 / 68 ESR. r=ewright

Turns off the content blocking UI tour to avoid annoying and confusing users. Approved for 69.0b10 and 68.1esr.

Attachment #9081619 - Flags: approval-mozilla-esr68?
Attachment #9081619 - Flags: approval-mozilla-esr68+
Attachment #9081619 - Flags: approval-mozilla-beta?
Attachment #9081619 - Flags: approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
QA Whiteboard: [qa-triaged]

Verified that the ui tour is disabled on 69.0b10 and 68.0esr build from treeherder, across platforms (Windows 10 64bit, macOS 10.13.6 and Ubuntu 18.04 64bit).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.