Closed Bug 1569892 Opened 6 months ago Closed 6 months ago

Allow for Fluent files that are not ready for localization

Categories

(Core :: Internationalization, defect, P1, blocker)

defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 68+ fixed
firefox68 blocking fixed
firefox69 blocking fixed
firefox70 + fixed

People

(Reporter: Pike, Assigned: Pike)

References

Details

(Keywords: rca-needed)

Attachments

(2 files)

Our current approach for packaging Fluent that's not ready for l10n doesn't work.

What we did was packaging the pre-release files in the same /localization path as we will in prod.

At repack time, that breaks all kinds of things once you actually have them in localizations, as we see in bugs 1568438, 1569807.

I'm still counting on how many streams we cross, filing this in Intl right now, but I might also move this.

Here's what we need to keep from the current behavior:

  • The ftl files from content are packages for all locales, as if they were localized. That's a workaround for bug 1464156.
  • We can change the contents in content ftl files freely, w/out having to care about IDs.

I read the latter to mean that we can't use the localized fluent file as a drop-in replacement for a content one, in a cross-channel world. The IDs we have on l10n-central might overlap with different content-content.

Thus, we should have distinct path locations for these files. I propose that we should have use preview/aboutLogins.ftl instead of browser/aboutLogins.ftl.

Now, there's an interesting question around packaging. We can continue to do what we do now, and package the files a few times. Or we could package them once in a known location in omni.ja, and add to browser/l10n-registry.manifest a line like

category l10n-registry 0-preview resource://app/fluent-content/

(and move toolkit to 2).

Given that this would be the last location to look at in regular builds, I don't think this should come with perf problems. Maybe as a follow-up?

[Tracking Requested - why for this release]:

Requesting tracking for 69 and 68 esr, 'cause this is required to take string updates, see bug 1569807.

Pushed something to try, let's see how that goes: https://treeherder.mozilla.org/#/jobs?repo=try&revision=7817d73d6fdc68430e82de794a7adeec1a3b7f20. That patch won't apply to beta or esr at all, but the concept of it should.

Assignee: nobody → l10n
See Also: → 1569807

Having these files in their final packaged locations creates problems when
we expose them to localizations.

Bugbug thinks this bug is a enhancement, but please change it back in case of error.

Type: defect → enhancement

This is the beta variation of D39872.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ddb0015f0bede2e6b777cf24177971a91eb1ef46 is trying beta repacks now.

The same patch mostly applies to 68 and 68esr, aside from chunk to browser/components/aboutlogins/AboutLoginsParent.jsm, which isn't needed.

Type: enhancement → defect

This is green on beta for linux and windows. There's an unrelated bustage on macos, as that's mismatching Firefox Nightly.app and Firefox.app, that's unrelated to this bug.

Comment on attachment 9081606 [details]
Bug 1569892, move in-progress fluent files to preview locations, r=jaws

Beta/Release Uplift Approval Request

  • User impact if declined: We can't take updates to l10n on beta
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This succeeded on try, and has feedback from releng, l10n, and firefox engineering.
  • String changes made/needed: None
Attachment #9081606 - Flags: approval-mozilla-beta?

Comment on attachment 9081606 [details]
Bug 1569892, move in-progress fluent files to preview locations, r=jaws

Beta/Release Uplift Approval Request

  • User impact if declined: We can't take string updates for 68/esr68.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: We can't take string updates for 68/esr68, which we want for a ESR bug.
  • User impact if declined: We can't take string updates for 68/esr68.
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String or UUID changes made by this patch:
Attachment #9081606 - Flags: approval-mozilla-release?
Attachment #9081606 - Flags: approval-mozilla-esr68?
Pushed by axel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c94da5ac908
move in-progress fluent files to preview locations, r=johannh
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9081606 [details]
Bug 1569892, move in-progress fluent files to preview locations, r=jaws

Un-breaks Beta l10n repacks. Approved for 69.0b10.

Attachment #9081606 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9081606 [details]
Bug 1569892, move in-progress fluent files to preview locations, r=jaws

Today's b10 build went great with this patch. Approving for 68.0.2/68.0.2esr as well.

Attachment #9081606 - Flags: approval-mozilla-release?
Attachment #9081606 - Flags: approval-mozilla-release+
Attachment #9081606 - Flags: approval-mozilla-esr68?
Attachment #9081606 - Flags: approval-mozilla-esr68+

This bug has been identified as part of a pilot on determining root causes of blocking and dot release drivers.

It needs a root-cause set for it. Please see the list at https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/.

Add the root cause as a whiteboard tag in the form [rca - <cause> ] and remove the rca-needed keyword.

If you have questions, please contact :tmaity.

Keywords: rca-needed
You need to log in before you can comment on or make changes to this bug.