Closed Bug 1569948 Opened 1 year ago Closed 1 year ago

One-off search buttons missing if you click the Show history icon on the address bar and then type anything

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.2 - Jul 22 - Aug 4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: itiel_yn8, Assigned: dao)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot

Using Windows 10.

STR:

  1. Use a Nightly build that was built before bug 1551598 got fixed.
  2. (Optional, not sure if essential to the STR) Set intl.uidirection to 1 and restart
  3. Update Nightly to latest
  4. Type anything in the address bar

AR:
All of the one-off buttons are missing, and only "Search with" text and the cog icon are present.
Closing the autocomplete panel and reopening fixes this. This seems to be happening only on the first run after the update.

See attached.
This happened to me on my main profile at home the day after bug 1551598 got fixed, but I could reproduce this now on my (fairly) new profile at work (which was not updated in a while).

Flags: needinfo?(dao+bmo)
Priority: -- → P1
Summary: One-off search buttons missing on the first run after updating to any build built after bug 1551598 was fixed → One-off search buttons missing on the first run after updating a pre-bug 1551598 Nightly to any build built after bug 1551598 was fixed

It doesn't seem to make sense that you'd need a pre-bug 1551598 build first. Can you reproduce without that point?

Flags: needinfo?(dao+bmo) → needinfo?(itiel_yn8)

(In reply to Dão Gottwald [::dao] from comment #1)

It doesn't seem to make sense that you'd need a pre-bug 1551598 build first. Can you reproduce without that point?

Well, you're right.

New STR:

  1. Windows 10, latest Nightly
  2. Restart Nightly on a new tab
  3. Click the "Show history" icon on the address bar
  4. Start typing anything
Flags: needinfo?(dao+bmo)
Summary: One-off search buttons missing on the first run after updating a pre-bug 1551598 Nightly to any build built after bug 1551598 was fixed → One-off search buttons missing if you click the Show history icon on the address bar and then type anything
Assignee: nobody → dao+bmo
Iteration: --- → 70.2 - Jul 22 - Aug 4
Points: --- → 1
Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71c23430e052
Rebuild one-off search buttons when enabling them rather than when opening the view. r=mak
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+
QA Contact: cristian.comorasu

I can confirm this issue is fixed on Fx 70.0, 71.0b3 and 72.0a1(ar builds).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.