Closed Bug 157044 Opened 18 years ago Closed 16 years ago

Three paned cookie management for white/black/undecided

Categories

(Core :: Networking: Cookies, enhancement)

x86
All
enhancement
Not set

Tracking

()

VERIFIED WONTFIX

People

(Reporter: Bugzilla-alanjstrBugs, Assigned: mconnor)

References

Details

Attachments

(1 file)

There's a free utility on the internet called "Cookies Manager
(http://home.nordnet.fr/~pmdevigne/ )."  It only works for IE.  When new cookies
arrive, they are put into the 'new' bucket.  You have the option of choosing
between leaving them in the 'new' bucket, putting them in the 'keep' bucket, or
putting them in the 'delete' bucket. 

Mozilla uses the 'new/delete' method.  As the cookies pile up, this list can get
pretty long.  Every time you go in to Cookie Manager, you have to sort through
cookies you've already decided to keep.
Dup of bug 82734?

*** This bug has been marked as a duplicate of 74257 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
*** Bug 115471 has been marked as a duplicate of this bug. ***
There is a dupe chain that is 5 deep. I'm breaking it here, because I don't
think #2 was correct.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
-> defaults
Assignee: morse → darin
QA Contact: tever → cookieqa
Changing to FB, because I think it fits with the simplified point of view rather
well.  Trying to convince mconner to take this.
Component: Cookies → Preferences
Product: Browser → Firebird
Version: Trunk → unspecified
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Spamming mconnor
Summary: RFE Add "Cookies to Keep" option. → Three paned cookie management for white/black/undecided
Assignment requested by mconnor.  Futured.
Assignee: darin → mpconnor
ccing dwitte: this is the idea I mentioned on IRC, I don't remember if you had a
response to this one (machine was rebooted to XP by someone else)

Basically this would filter white/blacklisted cookies from the "Manage Cookies"
tab, since if you've already whitelisted/blacklisted the sites, you're probably
not going to want to keep examining the cookies.

thoughts?
This includes a recommendation from timeless: being able to mark a bug as
whitelist but session-only
QA Contact: cookieqa → bugzilla
This is just bulky and ugly and not my idea of usable.

What I could envision is allowing filtering the list of cookies by site
permissions.  Cookies from whitelisted sites would not be shown, allowing users
to focus on "new" cookies.  That would be better than this, and much more
compatible with the existing implementation of cookies, and allows keeping the
simpler list of cookies instead of a visually complex and potentially confusing
interface.

That really belongs in a new bug though, marking this WONTFIX since I don't
think this would be good for anyone below power-user status.
Status: NEW → RESOLVED
Closed: 18 years ago16 years ago
Resolution: --- → WONTFIX
V:WFX
I actually think our long term direction is to create some really awesome cookie
management interfaces for web developers... but I don't have bandwith to QA any
more UI anymore than anyone has time to code it :)
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → benc
-> cookies (why Firefox?)
Component: Preferences → Networking: Cookies
Product: Firefox → Core
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.