Closed Bug 1570727 Opened 3 months ago Closed 2 months ago

Clicking on an awesomebar result, but not the text, doesn't navigate to the page

Categories

(Firefox :: Address Bar, defect, P1)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: jaws, Assigned: mak)

References

(Regression)

Details

Attachments

(1 file)

STR:
Click on the (down) arrow within the location bar
In the popup, click your mouse on a suggestion but not on the text. Try to click within the top 5px of a suggestion.
Notice that the result is displayed as hovered.

AR:
The click is ignored and the popup stays open.

ER:
The page for the result is navigated to and the popup closes.

which OS? I can't reproduce on Win10

I can't reproduce this on macOS either.

Flags: needinfo?(jaws)

(In reply to Marco Bonardo [::mak] (Away 7-25 Aug) from comment #1)

which OS? I can't reproduce on Win10

(In reply to Drew Willcoxon :adw from comment #2)

I can't reproduce this on macOS either.

Same here on Ubuntu.

Sorry, I can reproduce this on 70.0a1 (2019-08-02) (64-bit) Nightly on Windows 10.

Flags: needinfo?(jaws)

I can only reproduce this with the Bookmarks Toolbar visible.

I have the bookmarks toolbar visible on the same version. Do you have any userchrome changes? Would you mind trying in a new profile or safe mode? I really can't see this bug, thus there must be something additional to make it happen.

Flags: needinfo?(jaws)

You might need to maximize your window to reproduce it. I always use a maximized window when browsing so didn't think of it, but when using a restored window I can't reproduce it anymore.

Flags: needinfo?(jaws)

I just reproduced this on Windows. It happens only for the first result, and with the window both maximized and non-maximized. I'll try to debug.

Assignee: nobody → adw
Iteration: --- → 70.3 - Aug 5 - 18
Points: --- → 3
Priority: -- → P2

Clicks are being sent to the bookmarks toolbar instead of the panel. You can actually click the top part of the first result and drag the window around.

Priority: P2 → P1

Removing -moz-window-dragging: inherit from #personal-bookmarks fixes it.

On macOS, clicks are sent to both the first result and the toolbar. You can drag the window, and on mouseup, the first result registers the click. You can also open the toolbar context menu on the first result (on both Windows and macOS).

I haven't had much time to work on this since I took the bug, so if anyone else would like to steal it, feel free. I started by trying to figure out how clicks originate in widget and how they end up being dispatched to the toolbar frame. We/I should probably ask someone who actually knows about that. I saw mconley had blame for some lines in widget that handle window dragging, so I thought I'd ask him, but he's away this week.

As a last resort, we could maybe remove -moz-window-dragging: inherit from #personal-bookmarks while the view is open and add it back once it closes.

Duplicate of this bug: 1575894
Duplicate of this bug: 1576403

(In reply to Drew Willcoxon :adw from comment #12)

As a last resort, we could maybe remove -moz-window-dragging: inherit from #personal-bookmarks while the view is open and add it back once it closes.

Imo, that rule should only be applied when #personal-bookmarks is outside PersonalToolbar. Afaict the original bug was that moving bookmarks onto the menubar didn't allow to drag the window anymore.

I can investigate this a little bit, if you wish, though not at the platform level.

Sure, feel free to take it. I probably won't work on it for the next few days.

Assignee: adw → mak77
Iteration: 70.3 - Aug 5 - 18 → 70.4 - Aug 19 - Sep 1
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/2ed7ceca1578
Clicking on the first Address Bar result fails with the bookmarks toolbar. r=dao
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Reproduced issue with 70.0a1 (2019-08-02).
Verified fix with 70.0b8 on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.