Closed Bug 1571450 Opened 6 months ago Closed 5 months ago

Snippet CTA and dismiss buttons are not visibly focused when using keyboard navigation

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: cmuresan, Assigned: emcminn)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(2 files)

[Affected versions]:

  • Firefox Nightly 70.0a1, Build ID 20190805095413

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have the browser.newtabpage.activity-stream.asrouter.devtoolsEnabled pref set to true.

[Steps to reproduce]:

  1. Start the browser with a new clean profile.
  2. Open a new tab and trigger a snippet with a button.
  3. Select part of the snippet's text.
  4. Press Tab once and observe the behavior.

[Expected results]:

  • The button is highlighted/visibly focused.

[Actual results]:

  • The button is focused without any feedback for the user.

[Notes]:

  • The issue is reproducible for all snippets with buttons.
  • The issue is also reproducible for snippets with links, but in this case only the "x" button has no user feedback when focused.
  • Attached a screen recording of the issue.
Assignee: nobody → emcminn

Setting this to p2 since this is an existing issue, not a regression caused by the new feature

Priority: -- → P2
Blocks: 1574334
Status: NEW → RESOLVED
Iteration: --- → 70.3 - Aug 5 - 18
Closed: 5 months ago
Keywords: github-merged
Priority: P2 → P1
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (70.0a1 Build ID - 20190816094815) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now the snippet's elements can be accessed through keyboard navigation.

Status: RESOLVED → VERIFIED

Emily, this seems edge-case enough that we can let the fix ride Fx70 to release? Otherwise, if you think we should uplift to Beta for Fx69, please attach a patch for uplift and nominate for approval as soon as possible. Thursday's Beta is the last one before 69 goes to RC.

Flags: needinfo?(emcminn)

Hi Ryan, let's not worry about uplifting this one - it's a pretty minor issue and waiting till Fx70 should be fine. Thanks!

Flags: needinfo?(emcminn)
You need to log in before you can comment on or make changes to this bug.