Closed Bug 1571761 Opened 2 years ago Closed 2 years ago

Add number of trackers blocked to ASRouterTargeting.jsm

Categories

(Firefox :: Messaging System, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1571763
Tracking Status
firefox69 --- unaffected
firefox70 --- affected

People

(Reporter: k88hudson, Unassigned)

References

Details

In order to support some targeting around suggesting the protection report in the What's new Panel, we would need to expose a "number of trackers blocked" in ASRouterTargeting.

To be able to do this, we would need to be able to call a function that providers this value (see https://searchfox.org/mozilla-central/source/browser/components/newtab/lib/ASRouterTargeting.jsm#373 for example)

Does this sound like something that is already available, or would some additional work need to be done to expose this information?

Flags: needinfo?(ewright)

(In reply to Kate Hudson :k88hudson from comment #1)

Does this sound like something that is already available, or would some additional work need to be done to expose this information?

This is already available, you can query the numbers of trackers blocked between two dates, or the total. These can be accessed using TrackingDBService.sumAllEvents(); or TrackingDBService.getEventsByDateRange(from, to);.

Flags: needinfo?(ewright)
Priority: -- → P2

This was added in bug 1571763 as totalBlockedCount

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1571763
You need to log in before you can comment on or make changes to this bug.