Closed Bug 1571763 Opened 2 months ago Closed 28 days ago

Message template for tracking protection report in what's new panel

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox69 --- unaffected
firefox70 --- verified

People

(Reporter: abenson, Assigned: andreio)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(2 files, 1 obsolete file)

Create a new message template for the What's New Panel that shows the total number of trackers blocked and a graph that shows the amount of trackers blocked since the last product release.

See Protections Update message here:
https://mozilla.invisionapp.com/share/XRT59JD49PN#/366467401_Whats_New_-_Skyline

Priority: -- → P2
Assignee: nobody → andrei.br92
Iteration: --- → 70.4 - Aug 19 - Sep 1
Priority: P2 → P1
Duplicate of this bug: 1575931
Blocks: 1576284
Status: NEW → RESOLVED
Closed: 28 days ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Duplicate of this bug: 1571761

This should be testable now on latest nightly with these prefs:

browser.messaging-system.whatsNewPanel.enabled
true

browser.newtabpage.activity-stream.asrouter.devtoolsEnabled
true

browser.newtabpage.activity-stream.asrouter.providers.panel_local_testing
{"id":"panel_local_testing", "cohort": "SHOW_TEST"}

After setting the prefs and visiting some pages where tracking protection blocks stuff, the whats new panel message should somewhat match up with about:protections (the timeframes are different I believe.. 1week in page vs 6 weeks in message vs all time in page ??)

I have verified this issue with the latest Firefox Nightly (70.0a1 Build ID - 20190827203416) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, the message template for the "Tracking Protection" report is successfully displayed in the "What's New" panel.

Status: RESOLVED → VERIFIED
Attachment #9087132 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.