Closed Bug 1571846 Opened Last month Closed Last month

`update_action` message does not set preference value after reset

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox69 --- verified
firefox70 --- verified

People

(Reporter: andreio, Assigned: andreio)

References

Details

(Keywords: github-merged)

We found some issues with the update_action message handling that could make the WNP fail to show up.
https://github.com/mozilla/activity-stream/pull/5223

Assignee: nobody → andrei.br92
Priority: -- → P1
Blocks: 1571115
Status: NEW → RESOLVED
Iteration: --- → 70.3 - Aug 5 - 18
Closed: Last month
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Could you provide QA steps for this? I believe the user facing bug is that a lower priority Moment message doesn't correctly get replaced by a higher priority message?

Flags: needinfo?(khudson)
QA Contact: cristian.comorasu

On a fresh profile:

  1. Set browser.newtabpage.activity-stream.asrouter.providers.panel_local_testing to {"id":"panel_local_testing", "cohort": "SHOW_TEST"}
  2. Set browser.newtabpage.activity-stream.asrouter.devtoolsEnabled to true
  3. Trigger WNP_THANK_YOU from asrouter admin

Expected:

  1. browser.startup.homepage_override.once is set
  2. After 5 minutes pref value is still set
Flags: needinfo?(khudson)

Tested using the mentioned steps. Please note that for the local trigger, it works as expected. Verified as fixed using Fx70.0a1 and Fx69.0b15 on windows 10 x64, ubuntu 18.04 and macOS 10.13 The message is still displayed after 5 minutes.

Please note that if a server message overrides the local WNP message, after 5 minutes the pref for 'browser.startup.homepage_override.once' is lost. This would not be desirable as per discussions, the server received message has a higher priority and will always override the local WNP message. Can you confirm if this is intended?

Status: RESOLVED → VERIFIED
Flags: needinfo?(khudson)
Flags: needinfo?(andrei.br92)

I can't reproduce any issues.

Flags: needinfo?(khudson)
Flags: needinfo?(andrei.br92)
You need to log in before you can comment on or make changes to this bug.