Closed Bug 1572109 Opened 1 year ago Closed 11 months ago

The focus remains blocked on the "Create New Login" button when using the "Tab" key to navigate if the "Edit/Create" mode is opened

Categories

(Firefox :: about:logins, defect, P2)

70 Branch
Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox68 --- unaffected
firefox69 --- disabled
firefox70 --- verified
firefox71 --- verified

People

(Reporter: cmuntean, Assigned: lnorton)

References

Details

(Keywords: access, Whiteboard: [passwords:management] [skyline][access-p2])

Attachments

(2 files)

[Affected Versions]:

  • Nightly 70.0a1

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]

  • Have a Firefox profile with at least one saved login.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page and select a saved login.
  3. Click the "Edit" button.
  4. Press the "Tab" key until the "Create New Login" button is focused.
  5. Press again the "Tab" key and observe the behavior.

[Expected results]:

  • The next element from the page gets focused.

[Actual results]:

  • The focus remains blocked on the "Create New Login" button.

[Notes]:

  • The issue is also reproducible when the "Create New Login" mode is opened.
  • Attached a screen recording with the issue.
Keywords: access
Priority: -- → P2
Flags: qe-verify+

The bug here is in the code that manually advances focus to the Edit button from the login-list. Since the Edit button is hidden in edit mode, focus doesn't move.

Assignee: nobody → lnorton
Status: NEW → ASSIGNED
See Also: → 1576175
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffa35308113f
Fix tabbing in edit mode. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Can you request uplift to beta? Thanks.

Flags: needinfo?(lnorton)

I have verified this issue on the latest Nightly 71.0a1 build on Windows 7 x64, Mac 10.14 and Ubuntu 16.04 x64.

  • The issue is not longer reproducible when you are in "Edit" mode. All the buttons can be focused using the "Tab" key.
  • But, it seems that the issue is still reproducible when the "Create New Login" mode is opened. I have logged a new issue for this in bug 1579818.

Considering this, I will mark this issue as verified fixed and will track the issue from "Create New Login" mode bug 1579818.

Status: RESOLVED → VERIFIED

Does this need Beta uplift?

Yes, it needs uplift. I am working with David Durst and MattN to coordinate a single uplift of multiple patches to make sure they land in order and are merged properly.

Flags: needinfo?(lnorton)
Whiteboard: [passwords:management] [skyline] → [passwords:management] [skyline][access-p2]

I have verified this issue on the Firefox Beta 70.0b8 (Build ID:20190919164641) build on Windows 10 x64, Mac 10.14 and Ubuntu 18.04 x64.

The issue is not longer reproducible when you are in "Edit" mode. All the buttons can be focused using the "Tab" key.
Flags: qe-verify+
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
Version: unspecified → 70 Branch
You need to log in before you can comment on or make changes to this bug.