Closed Bug 1576175 Opened 4 months ago Closed 3 months ago

[about:logins] Tab key doesn't select anything from the warning panel

Categories

(Firefox :: about:logins, defect, P2, minor)

70 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: oana.botisan, Assigned: jaws)

References

(Blocks 2 open bugs)

Details

(Keywords: access, Whiteboard: [passwords:management] [skyline][access-p1])

Attachments

(2 files)

Affected versions

  • Firefox 70.a01

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.13

Prerequisites

  • Have at least one breached site saved in the profile-- instructions on how to do this can be found here

Steps to reproduce

  1. Go to "about:logins".
  2. Press the "Tab" key until the "Learn more about this breach" hyperlink inside the warning banner is focused.

Expected result

  • The hyperlink is in focus.

Actual result

  • The hyperlink never gets in focus.

Regression range

  • I don't think this is a regression.

Additional notes

  • The same thing happens for the "X" (close) button.
  • The "X" (close) is in focus only if the user click on the warning banner, but the "Learn more about this breach" hyperlink still doesn't get in focus.
  • The only time the "Learn more about this breach" hyperlink gets in focus is when you click on the text inside the warning banner.
Whiteboard: [passwords:management] [skyline]
Keywords: access
Priority: -- → P2

You can tab backwards to the alert, so I think this is somewhat the same issue as bug 1572109 with the JS forcing the focus from the list to the edit button.

See Also: → 1572109
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e64bc498809
Move focus handling to login-item and forward focus to the breach alert when it is visible during tabbing. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

We verified the fix using lastest Nightly 71.0a1 on Ubuntu 18.04 x64, Windows 10 x64 and macOS 10.14. The issue is not reproducing anymore.

Hi jaws, could this be uplifted to beta?

Flags: needinfo?(jaws)
Whiteboard: [passwords:management] [skyline] → [passwords:management] [skyline][access-p1]

I verified the fix using Firefox 70.0b9 on Windows 10 x64, Ubuntu 18 x64 and macOS 10.13. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla71 → Firefox 71
You need to log in before you can comment on or make changes to this bug.