Closed Bug 1572118 Opened 2 months ago Closed Last month

Enable breach alerts in about:logins for all releases

Categories

(Toolkit :: Password Manager, task, P1)

70 Branch
task

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: groovecoder, Assigned: groovecoder)

References

(Blocks 1 open bug)

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

No description provided.
Assignee: nobody → lcrouch
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd38e8912378
enable about:logins breach-alerts r=sfoster
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

The feature isn't actually on by default as a new pref line got added above the old one instead of changing the old value…

+pref("signon.management.page.breach-alerts.enabled", true);
 pref("signon.management.overrideURI", "about:logins?filter=%DOMAIN%");
 pref("signon.management.page.breach-alerts.enabled", false);

Luke, can you attach a new patch to delete your added line and change the value of the old line?

Status: RESOLVED → REOPENED
Flags: qe-verify+
Flags: needinfo?(lcrouch)
Resolution: FIXED → ---
Whiteboard: [passwords:management] [skyline]
Target Milestone: mozilla70 → ---

Nevermind, I'll just do it to unblock the landing of https://phabricator.services.mozilla.com/D41034

Flags: needinfo?(lcrouch)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/9c5269817d0a
Actually enable about:logins breach-alerts by default

Backed out 2 changesets (Bug 1569846, Bug 1572118) for causing failures in browser_deleteLogin.js

Backout link: https://hg.mozilla.org/integration/autoland/rev/eb56d88d1b0758babf0ba4ac55fe261481833f09

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=windows%2C7%2Cshippable%2Copt%2Cmochitests%2Ctest-windows7-32-shippable%2Fopt-mochitest-browser-chrome-e10s-5%2Cm%28bc5%29&fromchange=a3480699468f683ae6f045828ccf54c6590e9815&tochange=eb56d88d1b0758babf0ba4ac55fe261481833f09&group_state=expanded&selectedJob=261717736

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=261717736&repo=autoland&lineNumber=3199

[task 2019-08-15T03:20:12.897Z] 03:20:12 INFO - Console message: [JavaScript Warning: "Sending message that cannot be cloned. Are you trying to send an XPCOM object?" {file: "resource://testing-common/ContentTask.jsm" line: 78}]
[task 2019-08-15T03:20:12.897Z] 03:20:12 INFO - Buffered messages finished
[task 2019-08-15T03:20:12.898Z] 03:20:12 INFO - TEST-UNEXPECTED-FAIL | browser/components/aboutlogins/tests/browser/browser_deleteLogin.js | Uncaught exception - Waiting for logins to be displayed - timed out after 50 tries.
[task 2019-08-15T03:20:12.898Z] 03:20:12 INFO - Leaving test bound test_show_logins
[task 2019-08-15T03:20:12.898Z] 03:20:12 INFO - Entering test bound test_login_item
[task 2019-08-15T03:20:12.898Z] 03:20:12 INFO - Clicking on the first login
[task 2019-08-15T03:20:12.898Z] 03:20:12 INFO - GECKO(1588) | console.warn: LoginHelper: "Couldn't parse origin for" "" ({})
[task 2019-08-15T03:20:12.937Z] 03:20:12 INFO - TEST-PASS | browser/components/aboutlogins/tests/browser/browser_deleteLogin.js | The login item should get populated - true == true -
[task 2019-08-15T03:20:12.952Z] 03:20:12 INFO - GECKO(1588) | JavaScript error: chrome://browser/content/aboutlogins/components/login-list.js, line 324: TypeError: this._logins[login.guid] is undefined
[task 2019-08-15T03:20:12.952Z] 03:20:12 INFO - TEST-PASS | browser/components/aboutlogins/tests/browser/browser_deleteLogin.js | Should not be in no logins view as there is still one login - true == true -
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - TEST-PASS | browser/components/aboutlogins/tests/browser/browser_deleteLogin.js | Should not be in no logins view as there is still one login - true == true -
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - Console message: [JavaScript Error: "TypeError: this._logins[login.guid] is undefined" {file: "chrome://browser/content/aboutlogins/components/login-list.js" line: 324}]
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - loginRemoved@chrome://browser/content/aboutlogins/components/login-list.js:324:5
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - @chrome://browser/content/aboutlogins/aboutLogins.js:51:27
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - sendToContent@resource:///actors/AboutLoginsChild.jsm:197:18
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - receiveMessage@resource:///actors/AboutLoginsChild.jsm:173:14
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - receiveMessage@resource://gre/modules/ActorManagerChild.jsm:179:30
[task 2019-08-15T03:20:12.953Z] 03:20:12 INFO - MessageListener.receiveMessageinit@resource://gre/modules/ActorManagerChild.jsm:67:15
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - init@resource://gre/modules/ActorManagerChild.jsm:215:11
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - onNewDocument@resource://gre/modules/ActorManagerChild.jsm:320:67
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - MozDocumentCallback.onNewDocument
init@resource://gre/modules/ActorManagerChild.jsm:309:21
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - @resource://gre/modules/ActorManagerChild.jsm:349:19
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - @chrome://global/content/browser-content.js:14:41
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO -
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - GECKO(1588) | console.warn: LoginHelper: "Couldn't parse origin for" "" ({})
[task 2019-08-15T03:20:12.954Z] 03:20:12 INFO - Clicking on the first login
[task 2019-08-15T03:20:13.053Z] 03:20:13 INFO - TEST-PASS | browser/components/aboutlogins/tests/browser/browser_deleteLogin.js | The login item should get populated - true == true -

Flags: needinfo?(MattN+bmo)

I believe the failure was caused by bug 1569846, not this one.

Flags: needinfo?(MattN+bmo)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/e39c5a2cde3a
Actually enable about:logins breach-alerts by default r=groovecoder
Status: REOPENED → RESOLVED
Closed: Last monthLast month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.