Closed Bug 1572671 Opened 4 months ago Closed 3 months ago

Multi-proxy Browser Console can't be re-opened

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox70 verified)

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission)

Attachments

(1 file)

Steps to reproduce

  1. Open the Browser console with the browser toolbox fission pref
  2. Close it
  3. Re-open it

Actual results

The Browser Console is blank

No longer blocks: 1572435
No longer depends on: 1572414
Summary: Multi-proxy Browser Console can-t be re-opened → Multi-proxy Browser Console can't be re-opened

Previously, we were simply having a flag on the ContentProcessConnector
that we would flip once we loaded the content process server startup script.
This was working fine until multi-proxy browser console.
Each time we open the Browser Console, we create a new loader in a new
compartment. Which means in the end we'll have a new ContentProcessConnector
instance, and the flag would be resetted, and thus we would load a new
content process server startup script, which finally, would emit some
packet twice, and thus would break how we manage new packet in the client.

This patch fixes that by replacing the flag by checking if the script
was already loaded. Since we don't need the flag and the ContentProcessConnector
object only holds a function, we directly turn the object into a function.

Blocks: 1577092
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a111ae683fa
Don't load content process server startup script if it was already loaded. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Flags: qe-verify+
QA Contact: vlad.lucaci

With devtools.browsertoolbox.fission set on true managed to confirm the issue on Windows 10 with 70.0a1 (2019-08-19).
Fix verified with 70.b7 on Windows 10, macOS 10.13, Ubuntu 16.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.