Closed Bug 1572786 Opened 1 year ago Closed 5 months ago

Remove the Gecko profiler add-on and migrate to the profiler popup

Categories

(DevTools :: Performance Tools (Profiler/Timeline), task, P2)

task

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: gregtatum, Assigned: gregtatum)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

Right now we need to wrap up a few dependent bugs before we can turn it on for everyone. From a discussion on Slack we'll probably use the UI migration code.

https://searchfox.org/mozilla-central/rev/9775cca0a10a9b5c5f4e15c8f7b3eff5bf91bbd0/browser/components/BrowserGlue.jsm#2689

We can use the AddonManager to check for the existence of the gecko profiler add-on.

Then we can add it.

(await AddonManager.getAllAddons()).find(({id}) => id === "geckoprofiler@mozilla.com").uninstall()

I'm not sure if we need some additional UI to display to the user explaining what happened, or if swapping things out is sufficient.

Priority: -- → P2
Blocks: 1566920
Depends on: 1553613, 1566986, 1553305
Component: Gecko Profiler → Performance Tools (Profiler/Timeline)
Product: Core → DevTools
Version: unspecified → Trunk

Here is the workflow for migrating users:

  • Check if the add-on is installed
  • If it is, uninstall it, and enable the popup.
  • Open up a tab with something like profiler.firefox.com/migration with a message explaining what we just did.
Blocks: 1603232
No longer depends on: 1553305
Duplicate of this bug: 1612516
Assignee: nobody → gtatum

This patch adds an upgrader to remove the Gecko Profiler Addon if
it is installed. If the addon was also enabled, it adds the profiler
menu button to the navbar.

Depends on D66785

Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6afede62221b
Remove the Gecko profiler add-on and migrate to the profiler popup; r=canaltinova
Flags: needinfo?(gtatum)
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e86e00c78134
Remove the Gecko profiler add-on and migrate to the profiler popup; r=canaltinova
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4695dbc761d7
Remove the Gecko profiler add-on and migrate to the profiler popup; r=canaltinova
Flags: needinfo?(gtatum)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
You need to log in before you can comment on or make changes to this bug.