Closed Bug 1572827 Opened Last month Closed Last month

Thunderbird Theme installation from ATN doesn't work (TB 68)

Categories

(Thunderbird :: Add-Ons: General, defect)

defect
Not set

Tracking

(thunderbird_esr6868+ fixed, thunderbird69 fixed, thunderbird70 fixed)

VERIFIED FIXED
Thunderbird 70.0
Tracking Status
thunderbird_esr68 68+ fixed
thunderbird69 --- fixed
thunderbird70 --- fixed

People

(Reporter: jorgk, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 2 obsolete files)

Since I'm writing the release notes for TB 68, I thought I'll try a WE theme.

So I went to the add-ons manager, Recommendations, and "Thunderbird Suave" showed up. I clicked on it and got to a new page with an add-button.

I clicked it once, no feedback, so I clicked again and again. Nothing.

I went back to Themes, and the page was empty, although there should be Default, Light, Dark, etc. I closed the add-ons manager and opened it again. Low and behold, Suave had been added tree times, with a huge blue box "Downloaded [x]". I clicked the [x] twice to remove two of the three. There was no way to enable Suave. So I clicked on another theme, upon clicking "Back", the theme page was empty again.

Closed the add-ons manager, back to themes, Suave still there, once, with the blue box.

So summarising:

  • Adding a theme from ATN gives no feedback, you can add it various times.
  • Once added, it messes up the Theme page of the add-ons manager
  • There doesn't seem to be a way to enable it.

The good news it: Downloading it from ATN and installing it manually works.

Flags: needinfo?(sancus)
Flags: needinfo?(geoff)

Bug 1: This bug exists in 68, 69 beta, and also Daily.

The discovery pane links indeed seem to be broken in 68, 69 beta, and also Daily, and they produce an error in ExtensionsUI.jsm:

https://i.imgur.com/eh4TMxZ.png

This is a Thunderbird bug. Installation works fine in 60. I don't know if fixing it requires a client patch. It may be possible to patch the website, since some URLs work. It's only the URLs on the recommended part of the discovery pane that fail.

Bug 2: This bug exists in 68, 69 beta, but DOES NOT exist in Daily:

The installed Themes tab becomes completely blank(not even showing default themes) after you install a theme until you restart Thunderbird, at which point it fixes itself.

Note that this issue extends to add-on installation as well, not just themes... and it leads to a weirdly broken looking extension tab:

https://i.imgur.com/1WrtQFD.png

Flags: needinfo?(sancus)

Bug 2 is what I described in comment #0. I hadn't seen bug 1.

Blocks: tb68found

Apart from the fact that the recommendations page won't recommend any themes to me, I think I can reproduce these. I also think it's code we control so they should be fixable.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)

(In reply to Geoff Lankow (:darktrojan) from comment #3)

Apart from the fact that the recommendations page won't recommend any themes to me, I think I can reproduce these. I also think it's code we control so they should be fixable.

It should: Themes are the things with no icon, just a green puzzle piece. Two little birds, Airmail, Dark Fox, etc.

I think that's just random numbers messing with me.

(In reply to Geoff Lankow (:darktrojan) from comment #5)

I think that's just random numbers messing with me.

You can always get to theme installation by just searching for something, and then clicking the Themes section on the website menu, anyway.

Component: Theme → Add-Ons: General
Attached patch 1572827-sort-themes-1.diff (obsolete) — Splinter Review

This patch applies only to the old Add-On Manager, so 68 and 69. We overrode the sort order of the extensions list, but should bail out early for themes. (Not that bailing out early worked anyway, because I forgot to return after calling the real sort function.) :-/

Attachment #9085306 - Flags: review?(sancus)
Attachment #9085306 - Flags: approval-comm-esr68?
Attachment #9085306 - Flags: approval-comm-beta?
Attached patch 1572827-notifications-1.diff (obsolete) — Splinter Review

This applies to all versions. The global notifications code expects that things refer to the outer-most window, because it's from Firefox. However sometimes in Thunderbird those things refer to an inner window.

Attachment #9085307 - Flags: review?(mkmelin+mozilla)
Attachment #9085307 - Flags: approval-comm-esr68?
Attachment #9085307 - Flags: approval-comm-beta?
Comment on attachment 9085306 [details] [diff] [review]
1572827-sort-themes-1.diff

Did I just screw up? Yes.
Attachment #9085306 - Attachment is obsolete: true
Attachment #9085306 - Flags: review?(sancus)
Attachment #9085306 - Flags: approval-comm-esr68?
Attachment #9085306 - Flags: approval-comm-beta?

See comment 7.

Attachment #9085308 - Flags: review?(sancus)
Attachment #9085308 - Flags: approval-comm-esr68?
Attachment #9085308 - Flags: approval-comm-beta?
Comment on attachment 9085307 [details] [diff] [review]
1572827-notifications-1.diff

This patch is broken too! :-(
Attachment #9085307 - Attachment is obsolete: true
Attachment #9085307 - Flags: review?(mkmelin+mozilla)
Attachment #9085307 - Flags: approval-comm-esr68?
Attachment #9085307 - Flags: approval-comm-beta?

See comment 8.

Attachment #9085331 - Flags: review?(mkmelin+mozilla)
Attachment #9085331 - Flags: approval-comm-esr68?
Attachment #9085331 - Flags: approval-comm-beta?
Comment on attachment 9085331 [details] [diff] [review]
1572827-notifications-2.diff

Review of attachment 9085331 [details] [diff] [review]:
-----------------------------------------------------------------

Seems ok, r=mkmelin
Attachment #9085331 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 9085308 [details] [diff] [review]
1572827-sort-themes-2.diff

Can you check the other patch out too, Magnus? Probably will be done much faster than I will because I haven't done a TB build in a while.
Attachment #9085308 - Flags: review?(sancus) → review?(mkmelin+mozilla)
Comment on attachment 9085308 [details] [diff] [review]
1572827-sort-themes-2.diff

Review of attachment 9085308 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah looks good, r=mkmelin
Attachment #9085308 - Flags: review?(mkmelin+mozilla) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5fcdaaf9a166
Ensure global pop-up notifications uses the outer-most window when needed. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 70.0
Attachment #9085308 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9085331 [details] [diff] [review]
1572827-notifications-2.diff

I suggested on tb-drivers to redo TB 69 beta 3 to include this since it seems important enough to test it and get it fixed for 68, right, Wayne?
Flags: needinfo?(vseerror)
Attachment #9085331 - Flags: approval-comm-beta? → approval-comm-beta+

Yes, let's do it.

Flags: needinfo?(vseerror)
Version: unspecified → 68

Tested on TB 69 beta, seems to work, installed Suave.

Status: RESOLVED → VERIFIED
Attachment #9085308 - Flags: approval-comm-esr68? → approval-comm-esr68+
Attachment #9085331 - Flags: approval-comm-esr68? → approval-comm-esr68+

Installed Suave on TB 68 ESR. Seems to be working.

You need to log in before you can comment on or make changes to this bug.