Closed Bug 1572925 Opened 4 months ago Closed 4 months ago

"privacy.restrict3rdpartystorage.url_decorations" preference appeared/showed itself in "Important Locked Preferences" section in about:support/Troubleshooting Information after landing patches from bug #1571770

Categories

(Core :: Privacy: Anti-Tracking, defect)

70 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- verified
firefox70 --- verified

People

(Reporter: Virtual, Assigned: ehsan)

References

(Regression)

Details

(Keywords: nightly-community, regression, reproducible)

Attachments

(1 file)

STR1:

  1. Open about:support/Troubleshooting Information
  2. Go to "Important Locked Preferences" section

and see that "privacy.restrict3rdpartystorage.url_decorations" preference is listed as locked

:Virtual, could you try to find a regression range in using for example mozregression?

Found commit message:
Bug 1571770 - Part 2: Package antitracking.manifest in packaged builds; r=baku

Differential Revision:
https://phabricator.services.mozilla.com/D40844

Has Regression Range: --- → yes
Component: Untriaged → Privacy: Anti-Tracking
Product: Firefox → Core
Summary: "privacy.restrict3rdpartystorage.url_decorations" preference is locked → "privacy.restrict3rdpartystorage.url_decorations" preference is locked after landing patches from bug #1571770

Hello Ehsan - Comment 2 shows Bug 1571770 might be the regressing bug. Can you take a look? thanks.

Flags: needinfo?(ehsan)

This is working as expected. This isn't meant to be a preference for users to change. It is locked to avoid users accidentally modifying it.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(ehsan)
Resolution: --- → INVALID

Actually, we should probably not show this pref in about:support to avoid misleading people (since this isn't really an "important locked preference"). :-) The only reason this is a preference in the first place is that preferences give us a quick and dirty mechanism to share a small string from the parent process to content processes.

Let me write a quick fix for that.

Assignee: nobody → ehsan
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d13f6714fc13
Make sure that about:support doesn't list the URL decorations pref as an important locked preference; r=baku

Comment on attachment 9085555 [details]
Bug 1572925 - Make sure that about:support doesn't list the URL decorations pref as an important locked preference;

Beta/Release Uplift Approval Request

  • User impact if declined: Users who look at the Locked Preferences section of about:support may get confused.

(This is a low risk, nice-to-have patch, but really if we don't take it nothing super bad would happen.)

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It only affects the data that we show inside the Locked Preferences table in about:support, and has an automated test.
  • String changes made/needed: None
Attachment #9085555 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Comment on attachment 9085555 [details]
Bug 1572925 - Make sure that about:support doesn't list the URL decorations pref as an important locked preference;

Avoids showing a locked pref in about:support that we don't want visible there. Approved for 69.0b15.

Attachment #9085555 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 70.0a1 (2019-08-16) and in latest Mozilla Firefox Beta 69, so I'm marking this bug as VERIFIED.
Thank you very much! \o/

Status: RESOLVED → VERIFIED
Summary: "privacy.restrict3rdpartystorage.url_decorations" preference is locked after landing patches from bug #1571770 → "privacy.restrict3rdpartystorage.url_decorations" preference appeared/showed itself in "Important Locked Preferences" section in about:support/Troubleshooting Information after landing patches from bug #1571770
See Also: → 1590364
You need to log in before you can comment on or make changes to this bug.