No wait-cursor for very long IMAP operations - makes it look like things are broken

VERIFIED DUPLICATE of bug 156471

Status

MailNews Core
Networking: IMAP
VERIFIED DUPLICATE of bug 156471
16 years ago
9 years ago

People

(Reporter: resigned, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Many operations on IMAP accounts take significant time (e.g. one I just tried:
search several hundred emails, match about 150 [this is quick], then try to
MOVE/FILE the results in a local folder over a 56k link [this takes a minute or
more]).

Because there is NEVER any wait cursor, it can often appear to the user that
nothing has happened, and nothing is happening.

IIRC, one of the basic guidelines of UI design "User needs feedback to know
whether their command has: worked, failed, or is still "in-progress". :)
Duplicate of bug 156471 [No progress indicator for moving msgs to IMAP folder].
Reporter: Please reopen if you disagree.

*** This bug has been marked as a duplicate of 156471 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
QA Contact: huang → laurel
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.