Closed Bug 1573165 Opened 11 months ago Closed 11 months ago

[Enhancement] The user should be redirected directly to the "Firefox Monitor" website after clicking the "Get Monitor" button, if he is already logged in to "Firefox Sync"

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1567405
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox68 --- unaffected
firefox69 --- fix-optional
firefox70 --- fixed

People

(Reporter: mcoman, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(2 files)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Nightly 70.0a1 - Build ID: 20190812095530

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have a new Firefox profile with the "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" pref's value set to "true" in the "about:config" page;
  • You are logged in to "Firefox Sync";

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Navigate to "about:newtab#asrouter" and select the "snippets_local_testing" option from the "Messages" dropdown menu.
  3. Scroll to the bottom of the page and click the "Show" button from the "SPECIAL_SNIPPET_BUTTON_1" section.
  4. Click the "Collapse devtools" button from the top-right part of the page.
  5. Click the "Get monitor" button from the "Special Monitor" snippet and observe the behavior.

[Expected result]:

  • The user should be redirected to the "Firefox Monitor" website.

[Actual result]:

  • The "Sign in to continue to Firefox Monitor" page is opened.

[Notes]:

  • Attached a screen recording of the issue.
Iteration: --- → 70.3 - Aug 5 - 18
Priority: -- → P1

I investigated this with the FXA team it and seems like this is an issue on the services side. A fix was landed a few days ago: https://github.com/mozilla/fxa/pull/2056, it's expected to be in production by end-of-month.

I just tested the uplift patch, and I'm seeing account info / image + email address and no password field with a [Sign in] button when clicked ends up loading https://monitor.firefox.com/user/dashboard

stomlinson, is the oauth step the expected behavior allowing users a final confirmation of which account will be used? If so, I guess this bug can be resolved maybe fixed or wontfix?

Flags: needinfo?(stomlinson)

(In reply to Ed Lee :Mardak from comment #2)

Created attachment 9085525 [details]
no password but not direct to monitor

I just tested the uplift patch, and I'm seeing account info / image + email address and no password field with a [Sign in] button when clicked ends up loading https://monitor.firefox.com/user/dashboard

stomlinson, is the oauth step the expected behavior allowing users a final confirmation of which account will be used? If so, I guess this bug can be resolved maybe fixed or wontfix?

This is indeed the expected behavior. With the work that :rfkelly is doing to decouple "Signing into Firefox" from "Signing into Sync" [1] and the prompt=none flow [2] we just landed on the FxA side, the need to click "Sign in" will go away in the nearish future.

[1] - https://bugzilla.mozilla.org/show_bug.cgi?id=1570565
[2] - https://github.com/mozilla/fxa/pull/1150

Flags: needinfo?(stomlinson)

See also related discussion in https://bugzilla.mozilla.org/show_bug.cgi?id=1567405; it may be possible to consider this bug a dupe of that one.

The "click to sign in" experience is the best we can do for now, but there's discussion about having a smarter landing page for the handoff between Browser and Monitor that can do things to onboard the user into the server. If and when such a page exists, the snippet should probably use it.

See Also: → 1567405
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1567405
You need to log in before you can comment on or make changes to this bug.