Closed Bug 1573322 Opened 1 year ago Closed 1 year ago

OOP subframe loads do not block the load event of the parent window

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1559841
Fission Milestone M4

People

(Reporter: kmag, Unassigned)

References

(Blocks 1 open bug)

Details

The load event of a window should not fire until all of its initial subframes have also loaded. This is usually handled by adding the load groups of those frames to the load groups of the parent window. When a load is redirected to a different process, though, it gets a new load group in that process, and the original parent loses all track of it, which means its load event will generally fire before its OOP subframes, and code that interacts with those frames won't work as expected.

Isn't this a dup of bug 1559841?

Thanks. I thought there was already a bug for this but couldn't find it.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1559841
Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.