Closed Bug 1573829 Opened 2 years ago Closed 2 years ago

Port | Bug 524092 "View Image Info" command is not carried out if "Page Info" window is already opened| to SeaMonkey

Categories

(SeaMonkey :: Page Info, defect)

defect
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.67
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file, 1 obsolete file)

Port:

  • Bug 524092 - "View Image Info" command is not carried out if "Page Info" window is already opened
  • Bug 524092 - fix for compatibility with "View Frames" add-on
  • Bug 1058543 - Make page info work again in e10s
Attached patch add loadTab function (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Page Info might not always work
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9085436 - Flags: review?(frgrahl)
Attachment #9085436 - Flags: approval-comm-release?
Attachment #9085436 - Flags: approval-comm-esr60?
Comment on attachment 9085436 [details] [diff] [review]
add loadTab function

loadTab function:

> +  // set gImageElement if present
> +  if ("arguments" in window && window.arguments.length >= 1 &&
> +      window.arguments[0].imageElement)
> +    gImageElement = window.arguments[0].imageElement;

This doesn't seem to work when called from  win.resetPageInfo(args) in navigator.js.
The page info is reloaded but the image is not selected. 

Removing the if and using the same assignment as the Fx patch fixes it for me.
> // set gImageElement if present
> gImageElement = args && args.imageElement;

Makes also more sense because args is the actual argument here already.

See:
https://hg.mozilla.org/mozilla-central/rev/44ff9f905317
https://hg.mozilla.org/mozilla-central/rev/0d83b7b45431

r/a+ with that fixed.
Attachment #9085436 - Flags: review?(frgrahl)
Attachment #9085436 - Flags: review+
Attachment #9085436 - Flags: approval-comm-release?
Attachment #9085436 - Flags: approval-comm-release+
Attachment #9085436 - Flags: approval-comm-esr60?
Attachment #9085436 - Flags: approval-comm-esr60+

Fix missing change, carrying forward r/a+

Attachment #9085436 - Attachment is obsolete: true
Attachment #9086851 - Flags: review+
Attachment #9086851 - Flags: approval-comm-release+
Attachment #9086851 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/93c1fb77105c
Port |Bug 524092 - "View Image Info" command is not carried out if "Page Info" window is already opened| to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.