Closed Bug 1573924 Opened 4 months ago Closed 3 months ago

The Lockwise data is not restored after restarting the browser with focus on a different tab

Categories

(Firefox :: about:logins, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox70 --- verified

People

(Reporter: MattN, Assigned: jaws)

References

(Depends on 1 open bug)

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1571451 +++

[Affected Versions]:

  • Nightly 70.0a1 (Build ID: 20190805095413)

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Prerequisites]:

  • Have at least one saved login.

[Steps to reproduce]:

  1. Open the latest Nightly browser with the profile from prerequisites.
  2. Navigate to "about:logins" page.
  3. Open a website in a new tab (not about:newtab).
  4. Restart the browser (Ctrl+Shift+J then Ctrl+Alt+R keys).
  5. Wait until all tabs are loaded.
  6. Focus the "about:logins" page and observe the behavior.

[Expected results]:

  • The sidebar displays all the saved logins and the details of the first login from the list are shown on the right side.

[Actual results]:

  • The sidebar doesn't display any login and an example of login details is shown on the right side.

[Notes]:

  • The saved logins are restored if the page is refreshed.
  • Attached a screen recording with the issue.
Status: ASSIGNED → NEW
Assignee: ntim.bugs → nobody
Assignee: nobody → jaws
Status: NEW → ASSIGNED

FWIW, using the steps from comment 0, I was able to restore the tab correctly before and after my patch. Though my patch does add an automated test for this now.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffda592c113d
Load logins on domcontentloaded or pageshow, whichever is fired first to handle sessionrestore properly. r=MattN
Flags: qe-verify+
Attachment #9087871 - Attachment description: Bug 1573924 - Load logins on domcontentloaded or pageshow, whichever is fired first to handle sessionrestore properly. r?MattN → Bug 1573924 - Loosen origin checking due to bug 1576722. r?MattN
Attachment #9087871 - Attachment description: Bug 1573924 - Loosen origin checking due to bug 1576722. r?MattN → Bug 1573924 - Loosen actor child message sender checking due to bug 1576722. r?MattN
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c96f3ad6e07
Loosen actor child message sender checking due to bug 1576722. r=MattN,tjr
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I have verified this issue and is no longer reproducible on the latest Nightly 70.0a1 (2019-08-27)(64-bit) build on Windows 7 x64, Mac 10.14 and Arch Linux 4.12.

  • The data is restored after restarting the browser with focus on a different tab
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: 70 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.