Closed Bug 1573953 Opened Last month Closed Last month

Do not add impressions for moments page pref check

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.3 - Aug 5 - 18
Tracking Status
firefox69 --- verified
firefox70 --- verified

People

(Reporter: k88hudson, Assigned: k88hudson)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

We should not be adding impressions at the point we add a moments URL to the pref; in the future, we can add impressions to the point we show the moments page if necessary

Just documenting that the failure is that every 5 minutes, the once pref is cleared then rechecked if a message should be shown, but every time the once pref is set, an impression is associated to the message thus possibly hitting the daily frequency cap for the provider.

With this pref:

browser.newtabpage.activity-stream.asrouter.providers.cfr;{"id":"cfr-remote","enabled":true,"type":"remote-settings","bucket":"messaging-system","frequency":{"custom":[{"period":"daily","cap":1}]},"categories":["cfrAddons","cfrFeatures"]}

Assuming the staged message targeting matches (profile age "created" 365 days ago), after 5 minutes, the "once" pref would be set.
After another 5 minutes, the bug appears clearing the "once" pref. Instead, the "once" pref should still have the url (and an updated "expire" time).

Assignee: nobody → khudson
Keywords: github-merged
Iteration: --- → 70.3 - Aug 5 - 18
Priority: -- → P1
Blocks: 1574334
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

How can this be verified by QA? Could you please provide us with some steps?

Flags: needinfo?(khudson)
Flags: needinfo?(edilee)

On a fresh profile:

  1. Set browser.newtabpage.activity-stream.asrouter.providers.panel_local_testing to {"id":"panel_local_testing", "cohort": "SHOW_TEST"}
  2. Set browser.newtabpage.activity-stream.asrouter.devtoolsEnabled to true
  3. Wait for WNP_THANK_YOU to trigger (browser.startup.homepage_override.once is set after 5 minutes)

Expected:

  1. In the admin page the message is show to have (0 impressions) next to the name/buttons
  2. No IMPRESSION telemetry ping is sent for WNP_THANK_YOU
Flags: needinfo?(khudson)
Flags: needinfo?(edilee)

Tested using the steps provided by Andrei.
The issue is verified fixed using Fx70.0a1 and Fx69.0b15 on ubuntu 18.04, windows 10 x64 and macOS 10.13. The 'browser.startup.homepage_override.once' is correctly set after 5 minutes. No impressions are displayed on the message, inside the admin page.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.