Closed Bug 1574115 Opened 4 months ago Closed 4 months ago

Port bug 1573435 - Use toolchain fetches for more task kinds

Categories

(Thunderbird :: Build Config, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 70.0

People

(Reporter: darktrojan, Assigned: rjl)

References

Details

Attachments

(2 files)

Decision task broken.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/ecccd8455117
Port bug 1573435 - Use toolchain fetches for more task kinds; rs=bustage-fix DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Attachment #9085709 - Flags: review?(rob)
Target Milestone: --- → Thunderbird 70.0
Comment on attachment 9085709 [details] [diff] [review]
1574115-toolchains.diff

Review of attachment 9085709 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #9085709 - Flags: review?(rob) → review+
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/2f2113a4e5e4
Follow up: Fix path to sccache executable. rs=bustage-fix
Duplicate of this bug: 1574311
For failing macOS L10n repacks.
Assignee: geoff → rob
Attachment #9086132 - Flags: review?(jorgk)
Comment on attachment 9086132 [details] [diff] [review]
Follow-up: Fix paths to macOS filesystem tools

OK. I saw a whole lot more $MOZ_FETCHES_DIR in the bug we're porting.
Attachment #9086132 - Flags: review?(jorgk) → review+

Fortunately most of mozconfig comes from including Firefox's mozconfig files. The sccache file is one notable exception, and apparently so is the macOS l10n repack config.
Based on the changes in that bug, it looks like the two strings to replace are $topsrcdir and $TOOLTOOL_DIR.
I searched mail/config/mozconfigs for both. The remaining $topsrcdir references all point to other mozconfig files to include, so those are okay.
The $TOOLTOOL_DIR references point to the MAPI headers path, and since Windows builds seem to be working, I'm not inclined to change those.
I'm fairly certain this covers all of them.

Good. Thanks for the research :-)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/5db14b616149
Follow-up: Fix paths to macOS filesystem tools. r=jorgk

Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.