Closed Bug 1574363 Opened 5 months ago Closed 5 months ago

"Page colors" panel, colors and background settings cannot be set in Thunderbird 60.8.0 Mac

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: divinorumdevotee, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Already tried restarting with all add-ons disabled - still has the problem afterwards. A Windows user has determined that this bug does NOT appear on Windows 10 platform:
https://support.mozilla.org/en-US/questions/1266285 <----- an open unsolved question in the Support FORUM.

Attempt to set a background tile image, or color - or attempt to change font foreground color.

Actual results:

I cannot set the foreground colors on text or set a background graphic or color in Thunderbird 60.8.0 (Pretty much the ENTIRE "Page colors and background" panel is not working now.)

When I select the text I wish to turn to red <any color> and click the button to summon the color chooser, I can select a new color, but when I close the color chooser the text color remains black.

I selected a graphic for my background tile and it shows up in the "Page Colors" dialog box (photo attached) ... but not in the display pane OR in the message sent.
Selecting a new background color does nothing, also.

Changing the text default color in the colors and background dialog box has no effect.

Expected results:

When I select text and click the button to change the color - when I choose the color and close the color selector box - I expected the color of the text in the message to change from what it was.
When I select a background graphic tile in the "Page colors and background" dialog - I expected the page to display that background.
When I select a background color I expect the document I'm composing to show that background color.

Richard, can you please check this.

Flags: needinfo?(richard.marti)

This works for me on a new message.

Sea Mac, you wrote "Thunderbird 60.8.0", so it's not TB 68 which will be released soon.

Doesn't it work on new messages or do you have a message you're replying? If replying it could be that the original message set the styles and we can't override them.

Flags: needinfo?(richard.marti)
Version: 68 → 60

If I'm not using the latest version (67?) - where do I get It?

If none of you can recreate this: then perhaps I have a corrupted profile.
How do I create a test profile without losing my current one?

I'm using Mac 10.12 & it may not show up in later Mac OS's. What OS Are you on?

This happens on new messages as well as replies.

I'm using 10.14.

You could try a pre-release of TB 68 http://ftp.mozilla.org/pub/thunderbird/candidates/68.0-candidates/build2/ on a new profile. Start with -p to create one.

Can you check in preferences: Display, Formatting, Colors (button): Override the colors ... - How is that set?

Hmmmm. I'd love to know if it is reproducible for any one else on Mac OS 10.12 ... or if it is just my system that is misbehaving.

So, is 60.8.0 equal to TB 67 then?
TB in Mac doesn't have a "Display" menu ... does have a "Format" menu. The Radio Button for "Use Custom Colors" is Set (See above screen shot.)
How do I start TB 67 on a Mac "With -p"?

We don't have developer capacity to answer all those newbie questions. You've come to the developers' bug tracking system, so some basic advanced skills are assumed.

60.x is the current official version, 67 is an old beta, 68 is the next official version, and 69 is the current beta.

I didn't say "Display" menu, I said Preferences. Surely there is a display section as described. I tried setting the override and then no other colours take effect, which is what you're describing.

I don't know how you launch TB, typically you'd modify the shortcut that starts the binary. Can you get a command shell on Mac and start TB like that? Sadly this article https://support.mozilla.org/en-US/kb/using-multiple-profiles only gives the steps for Windows.

68 Build 3 - with a new profile it made for itself, in my profile folder - works fine with no problems.
Increasingly likely that my profile is corrupted - at least the color preferences part - since everything works OK on the beta.
Is there a way to make profile repairs ... or at least save all of the messages into a NEW profile ... for the original profile?

So, I'll know when I upgrade to the new TB 68 if it was my profile or the program. If I upgrade and the problem goes away ... it was a bug in this version. If I upgrade and the problem does not go away ... it was a bug in my profile.

(In reply to Jorg K (GMT+2) from comment #6)

Can you check in preferences: Display, Formatting, Colors (button): Override the colors ... - How is that set?

"Always"

Thanks for checking TB 68, that's your future extended support release (ESR) due out next week (we hope).

So it looks like some setting is wrong in your old profile since we've had TB 60 out for a year now and never heard about the issue. In any case, too late not to fix anything in TB 60.

Yes, "always" is pretty fatal, there you have it ;-)

I guess my old profile just broke at some point in the last month. Sorry to have bothered you ... if you need testing on Mac OS 10.12 to verify a different issue I'd be glad to participate in that one.

Is TB 68 going to have a compatible profile?
I'll just back up the new default it made and move ... one piece at a time starting with the message databases ... my old profile bits into the new working one ... quitting and relaunching between each piece's moves. When I find the rotten piece: I get the working one out of the backup of the new profile TB 68 made - and re-overwrite it - and relaunch again.

Ugh. Not a Bug. Close it, Please.

(In reply to Jorg K (GMT+2) from comment #12)

Yes, "always" is pretty fatal, there you have it ;-)

I set it to "Never" ... now every thing is OK again. I wonder when the Devil slipped in there and changed it?
In the immortal words of 'Homer Simpson' ... "D'Oh!!!!" (Slaps Forehead)

No profile surgery needed. Just an Errant setting Undetected (Except by Genius Developer.).

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID

And if you need testing on Mac OS 10.12 - to verify a different issue - I'd be glad to participate in that one.

Normally TB should upgrade from TB 60 to TB 68 automatically when the time comes.

Since you somehow created a new profile (and fixed the old one), you can just erase anything created in the new profile and copy everything over from the old to the new.

we've had TB 60 out for a year now and never heard about the issue

Agreed. Some recent fixes in this area https://mzl.la/2Z6l7ay - but because of timing looks like none match this bug

Summary: Thunderbird 60.8.0 Formatting errors on Mac OS X 10.12.6 → "Page colors" panel, colors and background settings cannot be set in Thunderbird 60.8.0 Mac

Wayne, it was a badly set pref, see comment #14.

I have seen some reports over the years of the :
Options/Preferences > Display > Formatting > colours
the 'override the colours specified by the content with my selections above' was set to 'Always' after an update/install.

https://support.mozilla.org/en-US/questions/1196201
https://support.mozilla.org/en-US/questions/1240193
https://support.mozilla.org/en-US/questions/1277826
Two people confirmed this in the last support mentioned above.

But not exactly all that common.

You need to log in before you can comment on or make changes to this bug.