Closed Bug 1574391 Opened 2 years ago Closed 2 years ago

Move old MathML reftests into layout/reftests/mathml

Categories

(Core :: MathML, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: fredw, Assigned: fredw)

Details

Attachments

(1 file)

Old tests involving MathML are outside the layout/reftests/mathml directory, which means they might not be tested when developing MathML patches until we run the whole reftests (see for example bug 1574087 comment 8). I just searched for the "math" string inside reftests and was able to categorize tests into "MathML-only" and "MathML mixed with other languages". I think we can at least move those of the first category.

I/ MathML-only Tests

./bugs/347496-1.xhtml ./bugs/347496-1-ref.xhtml
=> dynamic change to table lines

./bugs/345563-sub.xhtml ./bugs/345563-sup.xhtml
=> check that msub != msup

./bugs/347348-1.xhtml ./bugs/347348-1-ref.xhtml
=> dynamic removal of mo content

./bugs/355548-1.xml ./bugs/355548-1-ref.xml
./bugs/355548-2.xml ./bugs/355548-2-ref.xml
./bugs/355548-3.xml ./bugs/355548-3-ref.xml
./bugs/355548-4.xml ./bugs/355548-4-ref.xml
./bugs/355548-5.xml ./bugs/355548-5-ref.xml
=> MathML & fonts

./bugs/393760-1.xml ./bugs/393760-1-ref.xml
./bugs/393760-2.xml ./bugs/393760-2-ref.xml
=> MathML colors

./bugs/414123.xhtml ./bugs/414123-ref.xhtml
=> mathvariant=italic

II/ MathML mixed with other languages

./bugs/370692-1.xhtml ./bugs/370692-1-ref.xhtml
=> mtr@rowspan and HTML table

./bugs/373533-1.xhtml about:blank
./bugs/373533-2.xhtml about:blank
./bugs/373533-3.xhtml about:blank
=> XUL/MathML/HTML

./forms/input/number/number-reframe-anon-text-field.html ./forms/input/number/number-reframe-anon-text-field-ref.html
=> MathML and HTML form

./table-anonymous-boxes/162063-1.xhtml about:blank
=> MathML and HTML table (would need to be extracted)

./css-visited/mathml-links.html ./css-visited/mathml-links-ref.html
=> visited mathml links (run by layout/style/test/test_visited_reftests.html)

@Emilio: Before I try moving the tests from category II, WDYT about it? I think only mathml-links.html should stay where it is since "css visited" tests are handled specially. And maybe it makes sense to keep 162063-1.xhtml inside "table anonymous boxes" since the test is really about this. But for the others it really seems to be bugs caused by MathML, so it makes sense to move them.

Flags: needinfo?(emilio)

I think it makes perfect sense. The visited tests need to remain as-is because the harness is different, but +1 to move them.

Flags: needinfo?(emilio)
Attachment #9085984 - Attachment description: Bug 1574391 - Move old MathML reftests into layout/reftests/mathml. ? → Bug 1574391 - Move old MathML reftests into layout/reftests/mathml. r=emilio

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91f7769b3d7e
Move old MathML reftests into layout/reftests/mathml. r=emilio

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.